56cf789f9fe8cc61ed5b9613b37b052a0f69eb7f
[privoxy.git] / junkbuster-suse.spec
1 # $Id: junkbuster-suse.spec,v 1.3 2001/06/07 17:28:10 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-suse.spec,v $
29 # Revision 1.3  2001/06/07 17:28:10  swa
30 # cosmetics
31 #
32 # Revision 1.2  2001/06/07 17:18:44  swa
33 # header fixed
34 #
35 #
36 # neededforbuild  -ijb
37 # usedforbuild    -ijb aaa_base aaa_dir autoconf automake base bash bindutil binutils bison bzip compress cpio cracklib db devs diffutils e2fsprogs file fileutils findutils flex gawk gcc gdbm gdbm-devel gettext glibc glibc-devel gpm gppshare groff gzip kbd less libtool libz lx_suse make mktemp modutils ncurses ncurses-devel net-tools netcfg nkitb pam pam-devel patch perl pgp ps rcs rpm sendmail sh-utils shadow strace syslogd sysvinit texinfo textutils timezone unzip util-linux vim xdevel xf86 xshared
38
39 Vendor:       http://ijbswa.sourceforge.net
40 Distribution: defineme
41 Name:         junkbuster
42 Packager:     Stefan Waldherr <stefan@waldherr.org>
43
44 Copyright:    GPL
45 BuildRoot: /tmp/junkbuster-rpmbuild
46 Group:        Networking/Utilities
47 Provides:     ijb
48 Obsoletes:    ijb
49 Autoreqprov:  on
50 Version: 2.9
51 Release: 4
52 Summary:      The Internet Junkbuster
53 Source:  http://www.waldherr.org/junkbuster/ijbswa.tar.gz
54
55 #
56 # -----------------------------------------------------------------------------
57 #
58 %description
59 The Internet Junkbuster (TM) blocks unwanted banner ads and protects
60 your privacy from cookies and other threats. It's free under the GPL
61 (no warranty), runs under *NIX and works with almost any browser. You
62 need to clear you browser's cache and specify the proxy-server,
63 described in /usr/doc/junkbuster.  This is a modified version which
64 returns a blank GIF for blocked images by default.  But you can
65 configure this via /etc/junkbuster/config.
66
67 Authors:
68 --------
69     http://ijbswa.sourceforge.net
70
71 SuSE series: n
72
73 #
74 # -----------------------------------------------------------------------------
75 #
76 %prep
77 %setup -c -n ijbswa
78
79 #
80 # -----------------------------------------------------------------------------
81 #
82 %build
83 ./configure
84 make
85
86 #
87 # -----------------------------------------------------------------------------
88 #
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 mkdir -p $RPM_BUILD_ROOT/{var/log/junkbuster,usr/{sbin,share/man/man1},etc/{junkbuster,junkbuster/templates,init.d}}
92
93 install -m 755 junkbuster.init.suse $RPM_BUILD_ROOT/etc/init.d/junkbuster
94 ln -sf $RPM_BUILD_ROOT/etc/init.d/junkbuster $RPM_BUILD_ROOT/usr/sbin/rcjunkbuster
95
96 install -m 755 junkbuster $RPM_BUILD_ROOT/usr/sbin
97 install -d $RPM_BUILD_ROOT/etc/junkbuster
98 install -d $RPM_BUILD_ROOT/etc/junkbuster/templates
99 install -m 644 permissionsfile $RPM_BUILD_ROOT/etc/junkbuster
100 install -m 644 re_filterfile $RPM_BUILD_ROOT/etc/junkbuster
101 # verify all file locations, etc. in the config file
102 # don't start with ^ or commented lines are not replaced
103 cat config | \
104     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
105 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/junkbuster\/permissionsfile/g' | \
106 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
107 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
108 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
109 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
110 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
111     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
112     config.tmp
113 cp -f config.tmp config
114 install -m 644 config $RPM_BUILD_ROOT/etc/junkbuster
115 #install -m 644 forward $RPM_BUILD_ROOT/etc/junkbuster
116 install -m 644 trust $RPM_BUILD_ROOT/etc/junkbuster
117 install -m 644 templates/default $RPM_BUILD_ROOT/etc/junkbuster/templates
118 install -m 644 templates/show-status $RPM_BUILD_ROOT/etc/junkbuster/templates
119 install -m 644 templates/show-status-file $RPM_BUILD_ROOT/etc/junkbuster/templates
120 install -m 644 junkbuster.1 $RPM_BUILD_ROOT/usr/share/man/man1
121 %{?suse_check}
122
123 #
124 # -----------------------------------------------------------------------------
125 #
126 %post
127 sbin/insserv etc/init.d/junkbuster
128
129 #
130 # -----------------------------------------------------------------------------
131 #
132 %postun
133 sbin/insserv etc/init.d/
134
135 #
136 # -----------------------------------------------------------------------------
137 #
138 %files
139 #%doc README *.html
140 /usr/sbin/junkbuster
141 /usr/share/man/man1/junkbuster.1.gz
142 %config(noreplace) /etc/junkbuster
143 /etc/init.d/junkbuster
144 /usr/sbin/rcjunkbuster
145
146 #
147 # -----------------------------------------------------------------------------
148 #
149 %changelog -n junkbuster
150 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
151 - rework of RPM
152 * Wed Feb 14 2001 - uli@suse.de
153 - fixed init script
154 * Wed Dec 06 2000 - bjacke@suse.de
155 - renamed package to junkbuster
156 - fixed copyright tag
157 * Thu Nov 30 2000 - uli@suse.de
158 - moved init script to /etc/init.d
159 * Wed Feb 16 2000 - kukuk@suse.de
160 - Move /usr/man -> /usr/share/man
161 - Mark /etc/ijb as "config(noreplace)"
162 * Mon Sep 20 1999 - uli@suse.de
163 - fixed init script
164 * Mon Sep 13 1999 - bs@suse.de
165 - ran old prepare_spec on spec file to switch to new prepare_spec.
166 * Thu Apr 01 1999 - daniel@suse.de
167 - do not start ijb as root (security)
168 * Tue Mar 30 1999 - daniel@suse.de
169 - donĀ“t use saclfile.ini
170 * Tue Mar 30 1999 - daniel@suse.de
171 - small fix to whitelist-configuration,
172   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
173   (http://www.waldherr.org/junkbuster/)
174 * Mon Mar 01 1999 - daniel@suse.de
175 - new package: version 2.0