Replaced the hard limit for the maximum number of matches
[privoxy.git] / junkbuster-rh.spec
1 # $Id: junkbuster-rh.spec,v 1.10 2001/07/03 09:34:44 sarantis Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-rh.spec,v $
29 # Revision 1.10  2001/07/03 09:34:44  sarantis
30 # bumped up version number.
31 #
32 # Revision 1.9  2001/06/12 18:15:29  swa
33 # the % in front of configure (see tag below) confused
34 # the rpm build process on 7.1.
35 #
36 # Revision 1.8  2001/06/12 17:15:56  swa
37 # fixes, because a clean build on rh6.1 was impossible.
38 # GZIP confuses make, % configure confuses rpm, etc.
39 #
40 # Revision 1.7  2001/06/11 12:17:26  sarantis
41 # fix typo in %post
42 #
43 # Revision 1.6  2001/06/11 11:28:25  sarantis
44 # Further optimizations and adaptations in the spec file.
45 #
46 # Revision 1.5  2001/06/09 09:14:11  swa
47 # shamelessly adapted RPM stuff from the newest rpm that
48 # RedHat provided for the JB.
49 #
50 # Revision 1.4  2001/06/08 20:54:18  swa
51 # type with status file. remove forward et. al from file list.
52 #
53 # Revision 1.3  2001/06/07 17:28:10  swa
54 # cosmetics
55 #
56 # Revision 1.2  2001/06/04 18:31:58  swa
57 # files are now prefixed with either `confdir' or `logdir'.
58 # `make redhat-dist' replaces both entries confdir and logdir
59 # with redhat values
60 #
61 # Revision 1.1  2001/06/04 10:44:57  swa
62 # `make redhatr-dist' now works. Except for the paths
63 # in the config file.
64 #
65 #
66 #
67 Summary: The Internet Junkbuster
68 Vendor: http://ijbswa.sourceforge.net
69 Name: junkbuster
70 Version: 2.9.5
71 Release: 1
72 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
73 Copyright: GPL
74 BuildRoot: %{_tmppath}/%{name}-root
75 Group: Networking/Utilities
76 URL: http://ijbswa.sourceforge.net/
77 Packager: Stefan Waldherr <stefan@waldherr.org>
78 Obsoletes: junkbuster-raw junkbuster-blank
79 Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
80 Conflicts: junkbuster-raw junkbuster-blank
81
82 %description
83 The Internet Junkbuster stops your browser from displaying the
84 advertisement images that pervade many commercial web pages.  Since
85 your browser has to download fewer images, surfing the web should be
86 faster.
87
88 %define ijbconf %{_sysconfdir}/junkbuster
89
90 %prep
91 %setup -c -n ijbswa
92
93 %build
94 ./configure
95 make
96 strip junkbuster
97
98 %pre
99 /usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
104          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
105          ${RPM_BUILD_ROOT}/var/log/junkbuster \
106          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
107          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
108          ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
109
110 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
111 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
112 cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
113 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
114 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
115 cp -f templates/default $RPM_BUILD_ROOT%{ijbconf}/templates/
116 cp -f templates/show-status  $RPM_BUILD_ROOT%{ijbconf}/templates/
117 cp -f templates/show-status-file  $RPM_BUILD_ROOT%{ijbconf}/templates/
118 cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
119 install -m 755 junkbuster.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
120 install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
121
122 # verify all file locations, etc. in the config file
123 # don't start with ^ or commented lines are not replaced
124 cat config | \
125     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
126 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/junkbuster\/permissionsfile/g' | \
127 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
128 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
129 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
130 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
131 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
132     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
133     $RPM_BUILD_ROOT%{ijbconf}/config
134
135 %post
136 if [ "$1" = "1" ]; then
137         /sbin/chkconfig --add junkbuster
138 fi
139
140 %preun
141 if [ "$1" = "0" ]; then
142         /sbin/service junkbuster stop > /dev/null 2>&1 ||:
143         /sbin/chkconfig --del junkbuster
144 fi
145
146 %postun
147 if [ "$1" -ge "1" ]; then
148         /sbin/service junkbuster condrestart > /dev/null 2>&1
149 fi
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(-,root,root)
156 # %doc ijbfaq.html ijbman.html README README.TOO gpl.html
157 %doc junkbuster.weekly junkbuster.monthly
158 %dir %{ijbconf}
159 %config %{ijbconf}/*
160 %attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
161 %config %{_sysconfdir}/logrotate.d/junkbuster
162 %attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
163 %{_mandir}/man8/*
164 %config %{_sysconfdir}/rc.d/init.d/junkbuster
165
166
167 %changelog
168
169 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
170 - rework of RPM
171
172 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
173 - CLF Logging patch by davep@cyw.uklinux.net
174 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
175
176 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
177 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
178 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
179   numerous fixes and enhancements for Steve's patch.
180 - adamlock@netscape.com (Adam Lock) in the windows version:
181   - Taskbar activity spinner always spins even when logging is
182   turned off (which is the default) - people who don't
183   like the spinner can turn it off from a menu option.
184   - Taskbar popup menu has a options submenu - people can now
185   open the settings files for cookies, blockers etc.
186   without opening the JB window.
187   - Logging functionality works again
188   - Buffer overflow is fixed - new code uses a bigger buffer
189   and snprintf so it shouldn't overflow anymore.
190 - Fixed userid swa, group learning problem while installing.
191   root must build RPM.
192 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
193   core dump when there is no log file.
194 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
195 - Fixed man page to include imagefile and popupfile.
196 - Sanity check for the statistics function added.
197 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
198  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
199  With IIS/5, it appears to omit the trailing \r\n from http header
200  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
201  responds with a HTTP 302 redirect header.  However, this header
202  message is missing the trailing \r\n.  IIS/5 then closes the
203  connection.  Junkbuster, unfortunately, discards the header becomes
204  it thinks it is incomplete - and it is.  MS have transmitted an
205  incomplete header!
206 - Added bug reports and patch submission forms in the docs.
207
208 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
209        Andrew <anw@tirana.freewire.co.uk> extended the JB:
210        Display of statistics of the total number of requests and the number
211        of requests filtered by junkbuster, also the percentage of requests
212        filtered. Suppression of the listing of files on the proxy-args page.
213        All stuff optional and configurable.
214
215 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
216        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
217        code which prevented the JB from handling URLs of the form
218        user:password@www.foo.com. Fixed.
219
220 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
221         Blank images are no longer cached, thanks to a hint from Markus 
222         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
223         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
224         on the correct browser version nowadays. Incorporated many 
225         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
226         spec file. Fixed logging problem and since runlevel 2 does not 
227         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
228         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
229         <walker@netgate.net>. You should now be able to build this RPM as 
230         a non-root user (mathias@weidner.sem.lipsia.de).
231
232 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
233         /var/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
234         to allow more sophisticated matching of blocked images. Logrotate
235         logfile. Added files for auto-updating the blocklist et al.
236
237 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
238         Configure blank version via config file. No separate blank
239         version anymore. Added Roland's <roland@spinnaker.rhein.de>
240         patch to show a logo instead of a blank area. Added a suggestion
241         from Alex <alex@cocoa.demon.co.uk>: /var/lock/subsys/junkbuster.
242         More regexps in the blocklist. Prepared the forwardfile for
243         squid. Extended image regexp with help from gabriel 
244         <somlo@CS.ColoState.EDU>.
245
246 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
247         All RPMs now identify themselves in the show-proxy-args page.
248         Released Windoze version. Run junkbuster as nobody instead of
249         root. 
250
251 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
252         Newest version. First release (hence the little version number
253         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
254         security over 2.0.1; some multi-user sites will need to change 
255         the listen-address in the configuration file. The blank version of
256         the Internet Junkbuster has a more sophisticated way of replacing
257         images. All RPMs identify themselves in the show-proxy-args page.
258
259 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
260         Modified the blocking feature, so that only GIFs and JPEGs are
261         blocked and replaced but not HTML pages. Thanks to 
262         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
263         idea. Added numerous stuff to the blocklist. Keep patches in
264         seperate files and no longer in diffs (easier to maintain).
265
266 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
267         Moved config files to /etc/junkbuster directory, moved man page,
268         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
269         Made new version junkbuster-raw (which is only a stripped version of 
270         the junkuster rpm, i.e. without my blocklist, etc.)
271
272 * Tue Jun 16 1998 (2.0-1)
273         Uhm, not that much. Just a new junkbuster version that
274         fixes a couple of bugs ... and of course a bigger 
275         blocklist with the unique Now-less-ads-than-ever(SM)
276         feature.
277         Oh, one thing: I changed the default user agent to Linux -- no 
278         need anymore to support Apple.
279
280 * Tue Jun 16 1998 (2.0-0)
281         Now-less-ads-than-ever (SM)
282         compiled with gcc instead of cc
283         compiled with -O3, thus it should be a little faster
284         show-proxy-args now works
285         /etc/junkbuster.init wasn't necessary
286
287 * Tue Jun 16 1998 (1.4)
288         some more config files were put into /etc
289         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
290         displayed by Netscape instead of the blocked image.
291         Read http://www.waldherr.org/junkbuster/ for
292         further info.
293
294 * Tue Jun 16 1998 (1.3)
295         The program has been moved to /usr/sbin (from /usr/local/bin)
296         Init- and stopscripts (/etc/rc.d/rc*) have been added so
297         that the junkbuster starts automatically during bootup.
298         The /etc/blocklist file is much more sophisticated. Theoretically
299         one should e.g. browse all major US and German newspapers without
300         seeing one annoying ad.
301         junkbuster.init was modified. It now starts junkbuster with an
302         additional "-r @" flag.