buildroot definition in the specfile fucks up the build
[privoxy.git] / junkbuster-rh.spec
1 # $Id: junkbuster-rh.spec,v 1.11 2001/07/03 11:00:25 sarantis Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-rh.spec,v $
29 # Revision 1.11  2001/07/03 11:00:25  sarantis
30 # replaced permissionsfile with actionsfile
31 #
32 # Revision 1.10  2001/07/03 09:34:44  sarantis
33 # bumped up version number.
34 #
35 # Revision 1.9  2001/06/12 18:15:29  swa
36 # the % in front of configure (see tag below) confused
37 # the rpm build process on 7.1.
38 #
39 # Revision 1.8  2001/06/12 17:15:56  swa
40 # fixes, because a clean build on rh6.1 was impossible.
41 # GZIP confuses make, % configure confuses rpm, etc.
42 #
43 # Revision 1.7  2001/06/11 12:17:26  sarantis
44 # fix typo in %post
45 #
46 # Revision 1.6  2001/06/11 11:28:25  sarantis
47 # Further optimizations and adaptations in the spec file.
48 #
49 # Revision 1.5  2001/06/09 09:14:11  swa
50 # shamelessly adapted RPM stuff from the newest rpm that
51 # RedHat provided for the JB.
52 #
53 # Revision 1.4  2001/06/08 20:54:18  swa
54 # type with status file. remove forward et. al from file list.
55 #
56 # Revision 1.3  2001/06/07 17:28:10  swa
57 # cosmetics
58 #
59 # Revision 1.2  2001/06/04 18:31:58  swa
60 # files are now prefixed with either `confdir' or `logdir'.
61 # `make redhat-dist' replaces both entries confdir and logdir
62 # with redhat values
63 #
64 # Revision 1.1  2001/06/04 10:44:57  swa
65 # `make redhatr-dist' now works. Except for the paths
66 # in the config file.
67 #
68 #
69 #
70 Summary: The Internet Junkbuster
71 Vendor: http://ijbswa.sourceforge.net
72 Name: junkbuster
73 Version: 2.9.8
74 Release: 1
75 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
76 Copyright: GPL
77 BuildRoot: %{_tmppath}/%{name}-root
78 Group: Networking/Utilities
79 URL: http://ijbswa.sourceforge.net/
80 Packager: Stefan Waldherr <stefan@waldherr.org>
81 Obsoletes: junkbuster-raw junkbuster-blank
82 Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
83 Conflicts: junkbuster-raw junkbuster-blank
84
85 %description
86 The Internet Junkbuster stops your browser from displaying the
87 advertisement images that pervade many commercial web pages.  Since
88 your browser has to download fewer images, surfing the web should be
89 faster.
90
91 %define ijbconf %{_sysconfdir}/junkbuster
92
93 %prep
94 %setup -c -n ijbswa
95
96 %build
97 ./configure
98 make
99 strip junkbuster
100
101 %pre
102 /usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
107          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
108          ${RPM_BUILD_ROOT}/var/log/junkbuster \
109          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
110          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
111          ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
112
113 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
114 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
115 cp -f actionsfile $RPM_BUILD_ROOT%{ijbconf}/actionsfile
116 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
117 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
118 cp -f templates/*  $RPM_BUILD_ROOT%{ijbconf}/templates/
119 cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
120 install -m 755 junkbuster.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
121 install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
122
123 # verify all file locations, etc. in the config file
124 # don't start with ^ or commented lines are not replaced
125 cat config | \
126     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
127 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/junkbuster\/permissionsfile/g' | \
128 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
129 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
130 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
131 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
132 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
133     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
134     $RPM_BUILD_ROOT%{ijbconf}/config
135
136 %post
137 if [ "$1" = "1" ]; then
138         /sbin/chkconfig --add junkbuster
139 fi
140
141 %preun
142 if [ "$1" = "0" ]; then
143         /sbin/service junkbuster stop > /dev/null 2>&1 ||:
144         /sbin/chkconfig --del junkbuster
145 fi
146
147 %postun
148 if [ "$1" -ge "1" ]; then
149         /sbin/service junkbuster condrestart > /dev/null 2>&1
150 fi
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files
156 %defattr(-,root,root)
157 # %doc ijbfaq.html ijbman.html README README.TOO gpl.html
158 %doc junkbuster.weekly junkbuster.monthly
159 %dir %{ijbconf}
160 %config %{ijbconf}/*
161 %attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
162 %config %{_sysconfdir}/logrotate.d/junkbuster
163 %attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
164 %{_mandir}/man8/*
165 %config %{_sysconfdir}/rc.d/init.d/junkbuster
166
167
168 %changelog
169
170 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
171 - rework of RPM
172
173 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
174 - CLF Logging patch by davep@cyw.uklinux.net
175 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
176
177 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
178 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
179 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
180   numerous fixes and enhancements for Steve's patch.
181 - adamlock@netscape.com (Adam Lock) in the windows version:
182   - Taskbar activity spinner always spins even when logging is
183   turned off (which is the default) - people who don't
184   like the spinner can turn it off from a menu option.
185   - Taskbar popup menu has a options submenu - people can now
186   open the settings files for cookies, blockers etc.
187   without opening the JB window.
188   - Logging functionality works again
189   - Buffer overflow is fixed - new code uses a bigger buffer
190   and snprintf so it shouldn't overflow anymore.
191 - Fixed userid swa, group learning problem while installing.
192   root must build RPM.
193 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
194   core dump when there is no log file.
195 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
196 - Fixed man page to include imagefile and popupfile.
197 - Sanity check for the statistics function added.
198 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
199  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
200  With IIS/5, it appears to omit the trailing \r\n from http header
201  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
202  responds with a HTTP 302 redirect header.  However, this header
203  message is missing the trailing \r\n.  IIS/5 then closes the
204  connection.  Junkbuster, unfortunately, discards the header becomes
205  it thinks it is incomplete - and it is.  MS have transmitted an
206  incomplete header!
207 - Added bug reports and patch submission forms in the docs.
208
209 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
210        Andrew <anw@tirana.freewire.co.uk> extended the JB:
211        Display of statistics of the total number of requests and the number
212        of requests filtered by junkbuster, also the percentage of requests
213        filtered. Suppression of the listing of files on the proxy-args page.
214        All stuff optional and configurable.
215
216 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
217        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
218        code which prevented the JB from handling URLs of the form
219        user:password@www.foo.com. Fixed.
220
221 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
222         Blank images are no longer cached, thanks to a hint from Markus 
223         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
224         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
225         on the correct browser version nowadays. Incorporated many 
226         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
227         spec file. Fixed logging problem and since runlevel 2 does not 
228         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
229         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
230         <walker@netgate.net>. You should now be able to build this RPM as 
231         a non-root user (mathias@weidner.sem.lipsia.de).
232
233 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
234         /var/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
235         to allow more sophisticated matching of blocked images. Logrotate
236         logfile. Added files for auto-updating the blocklist et al.
237
238 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
239         Configure blank version via config file. No separate blank
240         version anymore. Added Roland's <roland@spinnaker.rhein.de>
241         patch to show a logo instead of a blank area. Added a suggestion
242         from Alex <alex@cocoa.demon.co.uk>: /var/lock/subsys/junkbuster.
243         More regexps in the blocklist. Prepared the forwardfile for
244         squid. Extended image regexp with help from gabriel 
245         <somlo@CS.ColoState.EDU>.
246
247 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
248         All RPMs now identify themselves in the show-proxy-args page.
249         Released Windoze version. Run junkbuster as nobody instead of
250         root. 
251
252 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
253         Newest version. First release (hence the little version number
254         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
255         security over 2.0.1; some multi-user sites will need to change 
256         the listen-address in the configuration file. The blank version of
257         the Internet Junkbuster has a more sophisticated way of replacing
258         images. All RPMs identify themselves in the show-proxy-args page.
259
260 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
261         Modified the blocking feature, so that only GIFs and JPEGs are
262         blocked and replaced but not HTML pages. Thanks to 
263         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
264         idea. Added numerous stuff to the blocklist. Keep patches in
265         seperate files and no longer in diffs (easier to maintain).
266
267 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
268         Moved config files to /etc/junkbuster directory, moved man page,
269         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
270         Made new version junkbuster-raw (which is only a stripped version of 
271         the junkuster rpm, i.e. without my blocklist, etc.)
272
273 * Tue Jun 16 1998 (2.0-1)
274         Uhm, not that much. Just a new junkbuster version that
275         fixes a couple of bugs ... and of course a bigger 
276         blocklist with the unique Now-less-ads-than-ever(SM)
277         feature.
278         Oh, one thing: I changed the default user agent to Linux -- no 
279         need anymore to support Apple.
280
281 * Tue Jun 16 1998 (2.0-0)
282         Now-less-ads-than-ever (SM)
283         compiled with gcc instead of cc
284         compiled with -O3, thus it should be a little faster
285         show-proxy-args now works
286         /etc/junkbuster.init wasn't necessary
287
288 * Tue Jun 16 1998 (1.4)
289         some more config files were put into /etc
290         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
291         displayed by Netscape instead of the blocked image.
292         Read http://www.waldherr.org/junkbuster/ for
293         further info.
294
295 * Tue Jun 16 1998 (1.3)
296         The program has been moved to /usr/sbin (from /usr/local/bin)
297         Init- and stopscripts (/etc/rc.d/rc*) have been added so
298         that the junkbuster starts automatically during bootup.
299         The /etc/blocklist file is much more sophisticated. Theoretically
300         one should e.g. browse all major US and German newspapers without
301         seeing one annoying ad.
302         junkbuster.init was modified. It now starts junkbuster with an
303         additional "-r @" flag.