fix typo in %post
[privoxy.git] / junkbuster-rh.spec
1 # $Id: junkbuster-rh.spec,v 1.6 2001/06/11 11:28:25 sarantis Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-rh.spec,v $
29 # Revision 1.6  2001/06/11 11:28:25  sarantis
30 # Further optimizations and adaptations in the spec file.
31 #
32 # Revision 1.5  2001/06/09 09:14:11  swa
33 # shamelessly adapted RPM stuff from the newest rpm that
34 # RedHat provided for the JB.
35 #
36 # Revision 1.4  2001/06/08 20:54:18  swa
37 # type with status file. remove forward et. al from file list.
38 #
39 # Revision 1.3  2001/06/07 17:28:10  swa
40 # cosmetics
41 #
42 # Revision 1.2  2001/06/04 18:31:58  swa
43 # files are now prefixed with either `confdir' or `logdir'.
44 # `make redhat-dist' replaces both entries confdir and logdir
45 # with redhat values
46 #
47 # Revision 1.1  2001/06/04 10:44:57  swa
48 # `make redhatr-dist' now works. Except for the paths
49 # in the config file.
50 #
51 #
52 #
53 Summary: The Internet Junkbuster
54 Vendor: http://ijbswa.sourceforge.net
55 Name: junkbuster
56 Version: 2.9.4
57 Release: 1
58 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
59 Copyright: GPL
60 BuildRoot: %{_tmppath}/%{name}-root
61 Group: Networking/Utilities
62 URL: http://ijbswa.sourceforge.net/
63 Packager: Stefan Waldherr <stefan@waldherr.org>
64 Obsoletes: junkbuster-raw junkbuster-blank
65 Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
66 Conflicts: junkbuster-raw junkbuster-blank
67
68 %description
69 The Internet Junkbuster stops your browser from displaying the
70 advertisement images that pervade many commercial web pages.  Since
71 your browser has to download fewer images, surfing the web should be
72 faster.
73
74 %define ijbconf %{_sysconfdir}/junkbuster
75
76 %prep
77 %setup -c -n %{name}-%{version}-%{release}
78 %build
79 %configure
80 make
81 strip junkbuster
82
83 %pre
84 /usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
89          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
90          ${RPM_BUILD_ROOT}/var/log/junkbuster \
91          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
92          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
93          ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
94
95 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
96 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
97 cp -f permissionsfile $RPM_BUILD_ROOT%{ijbconf}/permissionsfile
98 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
99 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
100 cp -f templates/default $RPM_BUILD_ROOT%{ijbconf}/templates/
101 cp -f templates/show-status  $RPM_BUILD_ROOT%{ijbconf}/templates/
102 cp -f templates/show-status-file  $RPM_BUILD_ROOT%{ijbconf}/templates/
103 cp -f junkbuster.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/junkbuster
104 install -m 755 junkbuster.init $RPM_BUILD_ROOT/etc/rc.d/init.d/junkbuster
105 install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
106
107 # verify all file locations, etc. in the config file
108 # don't start with ^ or commented lines are not replaced
109 cat config | \
110     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
111 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/junkbuster\/permissionsfile/g' | \
112 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
113 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
114 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
115 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
116 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
117     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
118     $RPM_BUILD_ROOT/etc/junkbuster/config
119
120 %post
121 if [ "$1" = "1" ]; then
122         /sbin/chkconfig --add junkbuster
123 fi
124
125 %preun
126 if [ "$1" = "0" ]; then
127         /sbin/service junkbuster stop > /dev/null 2>&1 ||:
128         /sbin/chkconfig --del junkbuster
129 fi
130
131 %postun
132 if [ "$1" -ge "1" ]; then
133         /sbin/service junkbuster condrestart > /dev/null 2>&1
134 fi
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(-,root,root)
141 # %doc ijbfaq.html ijbman.html README README.TOO gpl.html
142 %doc junkbuster.weekly junkbuster.monthly
143 %dir %{ijbconf}
144 %config %{ijbconf}/*
145 %attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
146 %config %{_sysconfdir}/logrotate.d/junkbuster
147 %attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
148 %{_mandir}/man8/*
149 %config /etc/rc.d/init.d/junkbuster
150
151
152 %changelog
153
154 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
155 - rework of RPM
156
157 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
158 - CLF Logging patch by davep@cyw.uklinux.net
159 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
160
161 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
162 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
163 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
164   numerous fixes and enhancements for Steve's patch.
165 - adamlock@netscape.com (Adam Lock) in the windows version:
166   - Taskbar activity spinner always spins even when logging is
167   turned off (which is the default) - people who don't
168   like the spinner can turn it off from a menu option.
169   - Taskbar popup menu has a options submenu - people can now
170   open the settings files for cookies, blockers etc.
171   without opening the JB window.
172   - Logging functionality works again
173   - Buffer overflow is fixed - new code uses a bigger buffer
174   and snprintf so it shouldn't overflow anymore.
175 - Fixed userid swa, group learning problem while installing.
176   root must build RPM.
177 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
178   core dump when there is no log file.
179 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
180 - Fixed man page to include imagefile and popupfile.
181 - Sanity check for the statistics function added.
182 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
183  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
184  With IIS/5, it appears to omit the trailing \r\n from http header
185  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
186  responds with a HTTP 302 redirect header.  However, this header
187  message is missing the trailing \r\n.  IIS/5 then closes the
188  connection.  Junkbuster, unfortunately, discards the header becomes
189  it thinks it is incomplete - and it is.  MS have transmitted an
190  incomplete header!
191 - Added bug reports and patch submission forms in the docs.
192
193 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
194        Andrew <anw@tirana.freewire.co.uk> extended the JB:
195        Display of statistics of the total number of requests and the number
196        of requests filtered by junkbuster, also the percentage of requests
197        filtered. Suppression of the listing of files on the proxy-args page.
198        All stuff optional and configurable.
199
200 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
201        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
202        code which prevented the JB from handling URLs of the form
203        user:password@www.foo.com. Fixed.
204
205 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
206         Blank images are no longer cached, thanks to a hint from Markus 
207         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
208         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
209         on the correct browser version nowadays. Incorporated many 
210         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
211         spec file. Fixed logging problem and since runlevel 2 does not 
212         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
213         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
214         <walker@netgate.net>. You should now be able to build this RPM as 
215         a non-root user (mathias@weidner.sem.lipsia.de).
216
217 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
218         /var/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
219         to allow more sophisticated matching of blocked images. Logrotate
220         logfile. Added files for auto-updating the blocklist et al.
221
222 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
223         Configure blank version via config file. No separate blank
224         version anymore. Added Roland's <roland@spinnaker.rhein.de>
225         patch to show a logo instead of a blank area. Added a suggestion
226         from Alex <alex@cocoa.demon.co.uk>: /var/lock/subsys/junkbuster.
227         More regexps in the blocklist. Prepared the forwardfile for
228         squid. Extended image regexp with help from gabriel 
229         <somlo@CS.ColoState.EDU>.
230
231 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
232         All RPMs now identify themselves in the show-proxy-args page.
233         Released Windoze version. Run junkbuster as nobody instead of
234         root. 
235
236 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
237         Newest version. First release (hence the little version number
238         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
239         security over 2.0.1; some multi-user sites will need to change 
240         the listen-address in the configuration file. The blank version of
241         the Internet Junkbuster has a more sophisticated way of replacing
242         images. All RPMs identify themselves in the show-proxy-args page.
243
244 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
245         Modified the blocking feature, so that only GIFs and JPEGs are
246         blocked and replaced but not HTML pages. Thanks to 
247         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
248         idea. Added numerous stuff to the blocklist. Keep patches in
249         seperate files and no longer in diffs (easier to maintain).
250
251 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
252         Moved config files to /etc/junkbuster directory, moved man page,
253         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
254         Made new version junkbuster-raw (which is only a stripped version of 
255         the junkuster rpm, i.e. without my blocklist, etc.)
256
257 * Tue Jun 16 1998 (2.0-1)
258         Uhm, not that much. Just a new junkbuster version that
259         fixes a couple of bugs ... and of course a bigger 
260         blocklist with the unique Now-less-ads-than-ever(SM)
261         feature.
262         Oh, one thing: I changed the default user agent to Linux -- no 
263         need anymore to support Apple.
264
265 * Tue Jun 16 1998 (2.0-0)
266         Now-less-ads-than-ever (SM)
267         compiled with gcc instead of cc
268         compiled with -O3, thus it should be a little faster
269         show-proxy-args now works
270         /etc/junkbuster.init wasn't necessary
271
272 * Tue Jun 16 1998 (1.4)
273         some more config files were put into /etc
274         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
275         displayed by Netscape instead of the blocked image.
276         Read http://www.waldherr.org/junkbuster/ for
277         further info.
278
279 * Tue Jun 16 1998 (1.3)
280         The program has been moved to /usr/sbin (from /usr/local/bin)
281         Init- and stopscripts (/etc/rc.d/rc*) have been added so
282         that the junkbuster starts automatically during bootup.
283         The /etc/blocklist file is much more sophisticated. Theoretically
284         one should e.g. browse all major US and German newspapers without
285         seeing one annoying ad.
286         junkbuster.init was modified. It now starts junkbuster with an
287         additional "-r @" flag.