Adding libtool to Buildrequires
[privoxy.git] / junkbuster-rh.spec
1 # $Id: junkbuster-rh.spec,v 1.37 2002/03/07 19:23:49 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define ijbconf %{_sysconfdir}/%{name}
31
32 Summary: The Internet Junkbuster
33 Vendor: http://ijbswa.sourceforge.net
34 Name: junkbuster
35 Version: 2.9.11
36 Release: 7
37 Source0: http://www.waldherr.org/%{name}/ijbswa-%{version}.tar.gz
38 License: GPL
39 BuildRoot: %{_tmppath}/%{name}-%{version}-root
40 Group: Networking/Utilities
41 URL: http://ijbswa.sourceforge.net/
42 Obsoletes: junkbuster-raw junkbuster-blank
43 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
44 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
45 BuildRequires: perl gzip sed docbook-utils libtool
46 Conflicts: junkbuster-raw junkbuster-blank
47
48 %description
49 Internet Junkbuster is a web proxy with advanced filtering
50 capabilities for protecting privacy, filtering web page content,
51 managing cookies, controlling access, and removing ads, banners,
52 pop-ups and other obnoxious Internet Junk. Junkbuster has a very
53 flexible configuration and can be customized to suit individual needs
54 and tastes. Internet Junkbuster has application for both stand-alone
55 systems and multi-user networks.
56
57 %prep
58 %setup -q -c -n ijbswa
59
60 %build
61 %configure
62 make 
63 make redhat-dok
64
65 ## Explicitily stripping is not recomended.
66 ## This is handled altomaticaly by RPM, and can couse troubles if
67 ## anyone wants to build an unstriped version - morcego
68 #strip %{name}
69
70 %install
71 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
72 mkdir -p %{buildroot}%{_sbindir} \
73          %{buildroot}%{_mandir}/man8 \
74          %{buildroot}%{_localstatedir}/log/%{name} \
75          %{buildroot}%{ijbconf}/templates \
76          %{buildroot}%{_sysconfdir}/logrotate.d \
77          %{buildroot}%{_sysconfdir}/rc.d/init.d 
78
79 ## Manual gziping of manpages should not be done, once it can
80 ## break the building on some distributions. Anyway, rpm does it
81 ## automagicaly these days
82 ## Gziping the documentation files is not recomended - morcego
83 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
84
85 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
86
87 ## We need to change the man section internaly on the manpage
88 ## -- morcego (sugestion by Hal Burgiss)
89 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
90 sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{name}.1 > %{buildroot}%{_mandir}/man8/%{name}.8
91 cp -f *.action %{buildroot}%{ijbconf}/
92 cp -f re_filterfile %{buildroot}%{ijbconf}/re_filterfile
93 cp -f trust %{buildroot}%{ijbconf}/trust
94 cp -f templates/*  %{buildroot}%{ijbconf}/templates/
95 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
96 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
97 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
98
99 # verify all file locations, etc. in the config file
100 # don't start with ^ or commented lines are not replaced
101 ## Changing the sed paramter delimiter to @, so we don't have to
102 ## escape the slashes
103 cat config | \
104     sed 's@^confdir.*@confdir %{_sysconfdir}/%{name}@g' | \
105 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
106 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/%{name}\/re_filterfile/g' | \
107 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
108 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
109 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
110 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
111     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
112     %{buildroot}%{ijbconf}/config
113 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' ijb.action >\
114     %{buildroot}%{ijbconf}/ijb.action
115
116 ## Macros are expanded even on commentaries. So, we have to use %%
117 ## -- morcego
118 #%%makeinstall
119
120 %pre
121 # We check to see if the user junkbuster exists.
122 # If it does, we do nothing
123 # If we don't, we check to see if the user junkbust exist and, in case it
124 # does, we change it do junkbuster. If it also does not exist, we create the
125 # junkbuster user -- morcego
126 id junkbuster > /dev/null 2>&1 
127 if [ $? -eq 1 ]; then
128         id junkbust > /dev/null 2>&1 
129         if [ $? -eq 0 ]; then
130                 /usr/sbin/usermod -l junkbuster -d %{_sysconfdir}/%{name} -s "" junkbust  > /dev/null 2>&1
131         else
132                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" junkbuster > /dev/null 2>&1 
133         fi
134 fi
135
136 %post
137 # for upgrade from 2.0.x
138 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
139  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
140 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
141 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
142 if [ "$1" = "1" ]; then
143      /sbin/chkconfig --add %{name}
144         /sbin/service %{name} condrestart > /dev/null 2>&1
145 fi
146 # 01/09/02 HB, getting rid of any user=junkbust
147 # Changed by morcego to use the id command.
148 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
149
150 %preun
151 if [ "$1" = "0" ]; then
152         /sbin/service %{name} stop > /dev/null 2>&1 ||:
153         /sbin/chkconfig --del %{name}
154 fi
155
156 %postun
157 #if [ "$1" -ge "1" ]; then
158 #       /sbin/service %{name} condrestart > /dev/null 2>&1
159 #fi
160
161 %clean
162 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
163
164 %files
165 %defattr(0644,root,root,0755)
166 %doc README AUTHORS ChangeLog
167 # Where are the webserver/{developer,user}-manual files ?
168 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
169 %doc doc/webserver/developer-manual
170 %doc doc/webserver/user-manual
171 #%doc %{name}.weekly %{name}.monthly AUTHORS
172
173 %dir %{ijbconf}
174 %dir %{ijbconf}/templates
175 %attr(0744,junkbuster,junkbuster) %dir %{_localstatedir}/log/%{name}
176
177 %attr(0744,junkbuster,junkbuster)%{_sbindir}/%{name}
178
179 # We should not use wildchars here. This could mask missing files problems
180 # -- morcego
181 %config %{ijbconf}/config
182 %config %{ijbconf}/ijb-advanced.action
183 %config %{ijbconf}/ijb-basic.action
184 %config %{ijbconf}/ijb-intermediate.action
185 %config %{ijbconf}/ijb.action
186 %config %{ijbconf}/re_filterfile
187 %config %{ijbconf}/trust
188
189 %config %{ijbconf}/templates/blocked
190 %config %{ijbconf}/templates/blocked-compact
191 %config %{ijbconf}/templates/cgi-error-404
192 %config %{ijbconf}/templates/cgi-error-bad-param
193 %config %{ijbconf}/templates/cgi-error-disabled
194 %config %{ijbconf}/templates/cgi-error-file
195 %config %{ijbconf}/templates/cgi-error-modified
196 %config %{ijbconf}/templates/cgi-error-parse
197 %config %{ijbconf}/templates/connect-failed
198 %config %{ijbconf}/templates/default
199 %config %{ijbconf}/templates/edit-actions-add-url-form
200 %config %{ijbconf}/templates/edit-actions-for-url
201 %config %{ijbconf}/templates/edit-actions-list
202 %config %{ijbconf}/templates/edit-actions-list-section
203 %config %{ijbconf}/templates/edit-actions-list-url
204 %config %{ijbconf}/templates/edit-actions-remove-url-form
205 %config %{ijbconf}/templates/edit-actions-url-form
206 %config %{ijbconf}/templates/no-such-domain
207 %config %{ijbconf}/templates/show-request
208 %config %{ijbconf}/templates/show-status
209 %config %{ijbconf}/templates/show-status-file
210 %config %{ijbconf}/templates/show-url-info
211 %config %{ijbconf}/templates/show-version
212 %config %{ijbconf}/templates/toggle
213 %config %{ijbconf}/templates/toggle-mini
214 %config %{ijbconf}/templates/untrusted
215
216 %config %{_sysconfdir}/logrotate.d/%{name}
217 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
218
219 %{_mandir}/man8/%{name}.8*
220
221 %changelog
222 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
223 + junkbuster-2.9.11-7
224 - Added BuildRequires to libtool.
225
226 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
227 + junkbuster-2.9.11-6
228 - Changed the routined that handle the junkbust and junkbuster users on
229   %%pre and %%post to work in a smoother manner
230 - %%files now uses hardcoded usernames, to avoid problems with package
231   name changes in the future
232
233 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
234 + junkbuster-2.9.11-5
235 - Added "make redhat-dok" to the build process
236 - Added docbook-utils to BuildRequires
237
238 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
239 + junkbuster-2.9.11-4
240 - Changing man section in the manpage from 1 to 8
241 - We now require packages, not files, to avoid issues with apt
242
243 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
244 + junkbuster-2.9.11-3
245 - Fixing permissions of the init script
246
247 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
248 + junkbuster-2.9.11-2
249 - General specfile fixup, using the best recomended practices, including:
250         - Adding -q to %%setup
251         - Using macros whereever possible
252         - Not using wildchars on %%files section
253         - Doubling the percentage char on changelog and comments, to
254           avoid rpm expanding them
255
256 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
257 - /bin/false for shell causes init script to fail. Reverting.
258
259 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
260 - Removed UID 73. Included user-manual and developer-manual in docs.
261   Include other actions files. Default shell is now /bin/false.
262   Userdel user=junkbust. ChangeLog was not zipped. Removed 
263   RPM_OPT_FLAGS kludge.
264
265 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
266 - add paranoia check for 'rm -rf %%{buildroot}'
267 - add gzip to 'BuildRequires'
268
269 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
270 - actionsfile is now ijb.action.
271
272 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
273 - Compress manpage
274 - Add more documents for installation
275 - Add version string to name and source
276
277 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
278 - Back to user 'junkbuster' and fix configure macro.
279
280 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
281 - More changes for user 'junkbust'. Init script had 'junkbuster'.
282
283 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
284 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
285 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
286
287 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
288 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
289 - made sure no default shell exists for user junkbust.
290
291 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
292 - rework of RPM
293
294 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
295 - CLF Logging patch by davep@cyw.uklinux.net
296 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
297
298 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
299 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
300 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
301   numerous fixes and enhancements for Steve's patch.
302 - adamlock@netscape.com (Adam Lock) in the windows version:
303   - Taskbar activity spinner always spins even when logging is
304   turned off (which is the default) - people who don't
305   like the spinner can turn it off from a menu option.
306   - Taskbar popup menu has a options submenu - people can now
307   open the settings files for cookies, blockers etc.
308   without opening the JB window.
309   - Logging functionality works again
310   - Buffer overflow is fixed - new code uses a bigger buffer
311   and snprintf so it shouldn't overflow anymore.
312 - Fixed userid swa, group learning problem while installing.
313   root must build RPM.
314 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
315   core dump when there is no log file.
316 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
317 - Fixed man page to include imagefile and popupfile.
318 - Sanity check for the statistics function added.
319 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
320  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
321  With IIS/5, it appears to omit the trailing \r\n from http header
322  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
323  responds with a HTTP 302 redirect header.  However, this header
324  message is missing the trailing \r\n.  IIS/5 then closes the
325  connection.  Junkbuster, unfortunately, discards the header becomes
326  it thinks it is incomplete - and it is.  MS have transmitted an
327  incomplete header!
328 - Added bug reports and patch submission forms in the docs.
329
330 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
331        Andrew <anw@tirana.freewire.co.uk> extended the JB:
332        Display of statistics of the total number of requests and the number
333        of requests filtered by junkbuster, also the percentage of requests
334        filtered. Suppression of the listing of files on the proxy-args page.
335        All stuff optional and configurable.
336
337 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
338        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
339        code which prevented the JB from handling URLs of the form
340        user:password@www.foo.com. Fixed.
341
342 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
343         Blank images are no longer cached, thanks to a hint from Markus 
344         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
345         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
346         on the correct browser version nowadays. Incorporated many 
347         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
348         spec file. Fixed logging problem and since runlevel 2 does not 
349         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
350         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
351         <walker@netgate.net>. You should now be able to build this RPM as 
352         a non-root user (mathias@weidner.sem.lipsia.de).
353
354 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
355         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
356         to allow more sophisticated matching of blocked images. Logrotate
357         logfile. Added files for auto-updating the blocklist et al.
358
359 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
360         Configure blank version via config file. No separate blank
361         version anymore. Added Roland's <roland@spinnaker.rhein.de>
362         patch to show a logo instead of a blank area. Added a suggestion
363         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
364         More regexps in the blocklist. Prepared the forwardfile for
365         squid. Extended image regexp with help from gabriel 
366         <somlo@CS.ColoState.EDU>.
367
368 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
369         All RPMs now identify themselves in the show-proxy-args page.
370         Released Windoze version. Run junkbuster as nobody instead of
371         root. 
372
373 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
374         Newest version. First release (hence the little version number
375         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
376         security over 2.0.1; some multi-user sites will need to change 
377         the listen-address in the configuration file. The blank version of
378         the Internet Junkbuster has a more sophisticated way of replacing
379         images. All RPMs identify themselves in the show-proxy-args page.
380
381 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
382         Modified the blocking feature, so that only GIFs and JPEGs are
383         blocked and replaced but not HTML pages. Thanks to 
384         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
385         idea. Added numerous stuff to the blocklist. Keep patches in
386         seperate files and no longer in diffs (easier to maintain).
387
388 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
389         Moved config files to /etc/junkbuster directory, moved man page,
390         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
391         Made new version junkbuster-raw (which is only a stripped version of 
392         the junkuster rpm, i.e. without my blocklist, etc.)
393
394 * Tue Jun 16 1998 (2.0-1)
395         Uhm, not that much. Just a new junkbuster version that
396         fixes a couple of bugs ... and of course a bigger 
397         blocklist with the unique Now-less-ads-than-ever(SM)
398         feature.
399         Oh, one thing: I changed the default user agent to Linux -- no 
400         need anymore to support Apple.
401
402 * Tue Jun 16 1998 (2.0-0)
403         Now-less-ads-than-ever (SM)
404         compiled with gcc instead of cc
405         compiled with -O3, thus it should be a little faster
406         show-proxy-args now works
407         /etc/junkbuster.init wasn't necessary
408
409 * Tue Jun 16 1998 (1.4)
410         some more config files were put into /etc
411         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
412         displayed by Netscape instead of the blocked image.
413         Read http://www.waldherr.org/junkbuster/ for
414         further info.
415
416 * Tue Jun 16 1998 (1.3)
417         The program has been moved to /usr/sbin (from /usr/local/bin)
418         Init- and stopscripts (/etc/rc.d/rc*) have been added so
419         that the junkbuster starts automatically during bootup.
420         The /etc/blocklist file is much more sophisticated. Theoretically
421         one should e.g. browse all major US and German newspapers without
422         seeing one annoying ad.
423         junkbuster.init was modified. It now starts junkbuster with an
424         additional "-r @" flag.
425
426 # $Log: junkbuster-rh.spec,v $
427 # Revision 1.37  2002/03/07 19:23:49  swa
428 # i hate to scroll. suse: wrong configdir.
429 #
430 # Revision 1.36  2002/03/07 05:06:54  morcego
431 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
432 #
433 # Revision 1.34  2002/03/07 00:11:57  morcego
434 # Few changes on the %pre and %post sections of the rh specfile to handle
435 # usernames more cleanly
436 #
437 # Revision 1.33  2002/03/05 13:13:57  morcego
438 # - Added "make redhat-dok" to the build phase
439 # - Added docbook-utils to BuildRequires
440 #
441 # Revision 1.32  2002/03/05 12:34:24  morcego
442 # - Changing section internaly on the manpage from 1 to 8
443 # - We now require packages, not files, to avoid issues with apt
444 #
445 # Revision 1.31  2002/03/04 18:06:09  morcego
446 # SPECFILE: fixing permissing of the init script (broken by the last change)
447 #
448 # Revision 1.30  2002/03/04 16:18:03  morcego
449 # General cleanup of the rh specfile.
450 #
451 # %changelog
452 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
453 # + junkbuster-2.9.11-2
454 # - General specfile fixup, using the best recomended practices, including:
455 #         - Adding -q to %%setup
456 #         - Using macros whereever possible
457 #         - Not using wildchars on %%files section
458 #         - Doubling the percentage char on changelog and comments, to
459 #           avoid rpm expanding them
460 #
461 # Revision 1.29  2002/03/03 19:21:22  hal9
462 # Init script fails if shell is /bin/false.
463 #
464 # Revision 1.28  2002/01/09 18:34:03  hal9
465 # nit.
466 #
467 # Revision 1.27  2002/01/09 18:32:02  hal9
468 # Removed RPM_OPT_FLAGS kludge.
469 #
470 # Revision 1.26  2002/01/09 18:21:10  hal9
471 # A few minor updates.
472 #
473 # Revision 1.25  2001/12/28 01:45:36  steudten
474 # Add paranoia check and BuildReq: gzip
475 #
476 # Revision 1.24  2001/12/01 21:43:14  hal9
477 # Allowed for new ijb.action file.
478 #
479 # Revision 1.23  2001/11/06 12:09:03  steudten
480 # Compress doc files. Install README and AUTHORS at last as document.
481 #
482 # Revision 1.22  2001/11/05 21:37:34  steudten
483 # Fix to include the actual version for name.
484 # Let the 'real' packager be included - sorry stefan.
485 #
486 # Revision 1.21  2001/10/31 19:27:27  swa
487 # consistent description. new name for suse since
488 # we had troubles with rpms of identical names
489 # on the webserver.
490 #
491 # Revision 1.20  2001/10/24 15:45:49  hal9
492 # To keep Thomas happy (aka correcting my  mistakes)
493 #
494 # Revision 1.19  2001/10/15 03:23:59  hal9
495 # Nits.
496 #
497 # Revision 1.17  2001/10/10 18:59:28  hal9
498 # Minor change for init script.
499 #
500 # Revision 1.16  2001/09/24 20:56:23  hal9
501 # Minor changes.
502 #
503 # Revision 1.13  2001/09/10 17:44:43  swa
504 # integrate three pieces of documentation. needs work.
505 # will not build cleanly under redhat.
506 #
507 # Revision 1.12  2001/09/10 16:25:04  swa
508 # copy all templates. version updated.
509 #
510 # Revision 1.11  2001/07/03 11:00:25  sarantis
511 # replaced permissionsfile with actionsfile
512 #
513 # Revision 1.10  2001/07/03 09:34:44  sarantis
514 # bumped up version number.
515 #
516 # Revision 1.9  2001/06/12 18:15:29  swa
517 # the %% in front of configure (see tag below) confused
518 # the rpm build process on 7.1.
519 #
520 # Revision 1.8  2001/06/12 17:15:56  swa
521 # fixes, because a clean build on rh6.1 was impossible.
522 # GZIP confuses make, %% configure confuses rpm, etc.
523 #
524 # Revision 1.7  2001/06/11 12:17:26  sarantis
525 # fix typo in %%post
526 #
527 # Revision 1.6  2001/06/11 11:28:25  sarantis
528 # Further optimizations and adaptations in the spec file.
529 #
530 # Revision 1.5  2001/06/09 09:14:11  swa
531 # shamelessly adapted RPM stuff from the newest rpm that
532 # RedHat provided for the JB.
533 #
534 # Revision 1.4  2001/06/08 20:54:18  swa
535 # type with status file. remove forward et. al from file list.
536 #
537 # Revision 1.3  2001/06/07 17:28:10  swa
538 # cosmetics
539 #
540 # Revision 1.2  2001/06/04 18:31:58  swa
541 # files are now prefixed with either `confdir' or `logdir'.
542 # `make redhat-dist' replaces both entries confdir and logdir
543 # with redhat values
544 #
545 # Revision 1.1  2001/06/04 10:44:57  swa
546 # `make redhatr-dist' now works. Except for the paths
547 # in the config file.
548 #
549 #
550 #