Removed logentry from cancelled commit
[privoxy.git] / junkbuster-rh.spec
1 # $Id: junkbuster-rh.spec,v 1.8 2001/06/12 17:15:56 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28 # $Log: junkbuster-rh.spec,v $
29 # Revision 1.8  2001/06/12 17:15:56  swa
30 # fixes, because a clean build on rh6.1 was impossible.
31 # GZIP confuses make, % configure confuses rpm, etc.
32 #
33 # Revision 1.7  2001/06/11 12:17:26  sarantis
34 # fix typo in %post
35 #
36 # Revision 1.6  2001/06/11 11:28:25  sarantis
37 # Further optimizations and adaptations in the spec file.
38 #
39 # Revision 1.5  2001/06/09 09:14:11  swa
40 # shamelessly adapted RPM stuff from the newest rpm that
41 # RedHat provided for the JB.
42 #
43 # Revision 1.4  2001/06/08 20:54:18  swa
44 # type with status file. remove forward et. al from file list.
45 #
46 # Revision 1.3  2001/06/07 17:28:10  swa
47 # cosmetics
48 #
49 # Revision 1.2  2001/06/04 18:31:58  swa
50 # files are now prefixed with either `confdir' or `logdir'.
51 # `make redhat-dist' replaces both entries confdir and logdir
52 # with redhat values
53 #
54 # Revision 1.1  2001/06/04 10:44:57  swa
55 # `make redhatr-dist' now works. Except for the paths
56 # in the config file.
57 #
58 #
59 #
60 Summary: The Internet Junkbuster
61 Vendor: http://ijbswa.sourceforge.net
62 Name: junkbuster
63 Version: 2.9.4
64 Release: 1
65 Source0: http://www.waldherr.org/junkbuster/ijbswa.tar.gz
66 Copyright: GPL
67 BuildRoot: %{_tmppath}/%{name}-root
68 Group: Networking/Utilities
69 URL: http://ijbswa.sourceforge.net/
70 Packager: Stefan Waldherr <stefan@waldherr.org>
71 Obsoletes: junkbuster-raw junkbuster-blank
72 Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
73 Conflicts: junkbuster-raw junkbuster-blank
74
75 %description
76 The Internet Junkbuster stops your browser from displaying the
77 advertisement images that pervade many commercial web pages.  Since
78 your browser has to download fewer images, surfing the web should be
79 faster.
80
81 %define ijbconf %{_sysconfdir}/junkbuster
82
83 %prep
84 %setup -c -n ijbswa
85
86 %build
87 ./configure
88 make
89 strip junkbuster
90
91 %pre
92 /usr/sbin/useradd -d /etc/junkbuster -u 73 -r junkbust > /dev/null 2>&1 || /bin/true
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
97          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
98          ${RPM_BUILD_ROOT}/var/log/junkbuster \
99          ${RPM_BUILD_ROOT}%{ijbconf}/templates \
100          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
101          ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
102
103 install -s -m 744 junkbuster $RPM_BUILD_ROOT%{_sbindir}/junkbuster
104 cp -f junkbuster.1 $RPM_BUILD_ROOT%{_mandir}/man8/junkbuster.8
105 cp -f permissionsfile $RPM_BUILD_ROOT%{ijbconf}/permissionsfile
106 cp -f re_filterfile $RPM_BUILD_ROOT%{ijbconf}/re_filterfile
107 cp -f trust $RPM_BUILD_ROOT%{ijbconf}/trust
108 cp -f templates/default $RPM_BUILD_ROOT%{ijbconf}/templates/
109 cp -f templates/show-status  $RPM_BUILD_ROOT%{ijbconf}/templates/
110 cp -f templates/show-status-file  $RPM_BUILD_ROOT%{ijbconf}/templates/
111 cp -f junkbuster.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/junkbuster
112 install -m 755 junkbuster.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/junkbuster
113 install -m 744 -d $RPM_BUILD_ROOT/var/log/junkbuster
114
115 # verify all file locations, etc. in the config file
116 # don't start with ^ or commented lines are not replaced
117 cat config | \
118     sed 's/^confdir.*/confdir \/etc\/junkbuster/g' | \
119 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/junkbuster\/permissionsfile/g' | \
120 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/junkbuster\/re_filterfile/g' | \
121 #    sed 's/^logfile.*/logfile \/var\/log\/junkbuster\/logfile/g' | \
122 #    sed 's/^jarfile.*/jarfile \/var\/log\/junkbuster\/jarfile/g' | \
123 #    sed 's/^forward.*/forward \/etc\/junkbuster\/forward/g' | \
124 #    sed 's/^aclfile.*/aclfile \/etc\/junkbuster\/aclfile/g' > \
125     sed 's/^logdir.*/logdir \/var\/log\/junkbuster/g' > \
126     $RPM_BUILD_ROOT%{ijbconf}/config
127
128 %post
129 if [ "$1" = "1" ]; then
130         /sbin/chkconfig --add junkbuster
131 fi
132
133 %preun
134 if [ "$1" = "0" ]; then
135         /sbin/service junkbuster stop > /dev/null 2>&1 ||:
136         /sbin/chkconfig --del junkbuster
137 fi
138
139 %postun
140 if [ "$1" -ge "1" ]; then
141         /sbin/service junkbuster condrestart > /dev/null 2>&1
142 fi
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(-,root,root)
149 # %doc ijbfaq.html ijbman.html README README.TOO gpl.html
150 %doc junkbuster.weekly junkbuster.monthly
151 %dir %{ijbconf}
152 %config %{ijbconf}/*
153 %attr(0744,junkbust,junkbust) %dir /var/log/junkbuster
154 %config %{_sysconfdir}/logrotate.d/junkbuster
155 %attr(0744,junkbust,junkbust)/usr/sbin/junkbuster
156 %{_mandir}/man8/*
157 %config %{_sysconfdir}/rc.d/init.d/junkbuster
158
159
160 %changelog
161
162 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
163 - rework of RPM
164
165 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
166 - CLF Logging patch by davep@cyw.uklinux.net
167 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
168
169 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
170 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
171 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
172   numerous fixes and enhancements for Steve's patch.
173 - adamlock@netscape.com (Adam Lock) in the windows version:
174   - Taskbar activity spinner always spins even when logging is
175   turned off (which is the default) - people who don't
176   like the spinner can turn it off from a menu option.
177   - Taskbar popup menu has a options submenu - people can now
178   open the settings files for cookies, blockers etc.
179   without opening the JB window.
180   - Logging functionality works again
181   - Buffer overflow is fixed - new code uses a bigger buffer
182   and snprintf so it shouldn't overflow anymore.
183 - Fixed userid swa, group learning problem while installing.
184   root must build RPM.
185 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
186   core dump when there is no log file.
187 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
188 - Fixed man page to include imagefile and popupfile.
189 - Sanity check for the statistics function added.
190 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
191  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
192  With IIS/5, it appears to omit the trailing \r\n from http header
193  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
194  responds with a HTTP 302 redirect header.  However, this header
195  message is missing the trailing \r\n.  IIS/5 then closes the
196  connection.  Junkbuster, unfortunately, discards the header becomes
197  it thinks it is incomplete - and it is.  MS have transmitted an
198  incomplete header!
199 - Added bug reports and patch submission forms in the docs.
200
201 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
202        Andrew <anw@tirana.freewire.co.uk> extended the JB:
203        Display of statistics of the total number of requests and the number
204        of requests filtered by junkbuster, also the percentage of requests
205        filtered. Suppression of the listing of files on the proxy-args page.
206        All stuff optional and configurable.
207
208 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
209        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
210        code which prevented the JB from handling URLs of the form
211        user:password@www.foo.com. Fixed.
212
213 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
214         Blank images are no longer cached, thanks to a hint from Markus 
215         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
216         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
217         on the correct browser version nowadays. Incorporated many 
218         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
219         spec file. Fixed logging problem and since runlevel 2 does not 
220         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
221         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
222         <walker@netgate.net>. You should now be able to build this RPM as 
223         a non-root user (mathias@weidner.sem.lipsia.de).
224
225 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
226         /var/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
227         to allow more sophisticated matching of blocked images. Logrotate
228         logfile. Added files for auto-updating the blocklist et al.
229
230 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
231         Configure blank version via config file. No separate blank
232         version anymore. Added Roland's <roland@spinnaker.rhein.de>
233         patch to show a logo instead of a blank area. Added a suggestion
234         from Alex <alex@cocoa.demon.co.uk>: /var/lock/subsys/junkbuster.
235         More regexps in the blocklist. Prepared the forwardfile for
236         squid. Extended image regexp with help from gabriel 
237         <somlo@CS.ColoState.EDU>.
238
239 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
240         All RPMs now identify themselves in the show-proxy-args page.
241         Released Windoze version. Run junkbuster as nobody instead of
242         root. 
243
244 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
245         Newest version. First release (hence the little version number
246         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
247         security over 2.0.1; some multi-user sites will need to change 
248         the listen-address in the configuration file. The blank version of
249         the Internet Junkbuster has a more sophisticated way of replacing
250         images. All RPMs identify themselves in the show-proxy-args page.
251
252 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
253         Modified the blocking feature, so that only GIFs and JPEGs are
254         blocked and replaced but not HTML pages. Thanks to 
255         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
256         idea. Added numerous stuff to the blocklist. Keep patches in
257         seperate files and no longer in diffs (easier to maintain).
258
259 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
260         Moved config files to /etc/junkbuster directory, moved man page,
261         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
262         Made new version junkbuster-raw (which is only a stripped version of 
263         the junkuster rpm, i.e. without my blocklist, etc.)
264
265 * Tue Jun 16 1998 (2.0-1)
266         Uhm, not that much. Just a new junkbuster version that
267         fixes a couple of bugs ... and of course a bigger 
268         blocklist with the unique Now-less-ads-than-ever(SM)
269         feature.
270         Oh, one thing: I changed the default user agent to Linux -- no 
271         need anymore to support Apple.
272
273 * Tue Jun 16 1998 (2.0-0)
274         Now-less-ads-than-ever (SM)
275         compiled with gcc instead of cc
276         compiled with -O3, thus it should be a little faster
277         show-proxy-args now works
278         /etc/junkbuster.init wasn't necessary
279
280 * Tue Jun 16 1998 (1.4)
281         some more config files were put into /etc
282         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
283         displayed by Netscape instead of the blocked image.
284         Read http://www.waldherr.org/junkbuster/ for
285         further info.
286
287 * Tue Jun 16 1998 (1.3)
288         The program has been moved to /usr/sbin (from /usr/local/bin)
289         Init- and stopscripts (/etc/rc.d/rc*) have been added so
290         that the junkbuster starts automatically during bootup.
291         The /etc/blocklist file is much more sophisticated. Theoretically
292         one should e.g. browse all major US and German newspapers without
293         seeing one annoying ad.
294         junkbuster.init was modified. It now starts junkbuster with an
295         additional "-r @" flag.