correct feedback channels
[privoxy.git] / junkbuster-rh.spec
1 # $Id: junkbuster-rh.spec,v 1.39 2002/03/08 18:57:29 swa Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # IJBSWA team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define ijbconf %{_sysconfdir}/%{name}
31
32 Summary: The Internet Junkbuster
33 Vendor: http://ijbswa.sourceforge.net
34 Name: junkbuster
35 Version: 2.9.11
36 Release: 8
37 Source0: http://www.waldherr.org/%{name}/ijbswa-%{version}.tar.gz
38 License: GPL
39 BuildRoot: %{_tmppath}/%{name}-%{version}-root
40 Group: Networking/Utilities
41 URL: http://ijbswa.sourceforge.net/
42 Obsoletes: junkbuster-raw junkbuster-blank
43 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
44 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
45 BuildRequires: perl gzip sed docbook-utils libtool
46 Conflicts: junkbuster-raw junkbuster-blank
47
48 %description
49 Internet Junkbuster is a web proxy with advanced filtering
50 capabilities for protecting privacy, filtering web page content,
51 managing cookies, controlling access, and removing ads, banners,
52 pop-ups and other obnoxious Internet Junk. Junkbuster has a very
53 flexible configuration and can be customized to suit individual needs
54 and tastes. Internet Junkbuster has application for both stand-alone
55 systems and multi-user networks.
56
57 %prep
58 %setup -q -c -n ijbswa
59
60 %build
61 %configure --enable-no-gifs 
62 make 
63 make redhat-dok
64
65 ## Explicitily stripping is not recomended.
66 ## This is handled altomaticaly by RPM, and can couse troubles if
67 ## anyone wants to build an unstriped version - morcego
68 #strip %{name}
69
70 %install
71 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
72 mkdir -p %{buildroot}%{_sbindir} \
73          %{buildroot}%{_mandir}/man8 \
74          %{buildroot}%{_localstatedir}/log/%{name} \
75          %{buildroot}%{ijbconf}/templates \
76          %{buildroot}%{_sysconfdir}/logrotate.d \
77          %{buildroot}%{_sysconfdir}/rc.d/init.d 
78
79 ## Manual gziping of manpages should not be done, once it can
80 ## break the building on some distributions. Anyway, rpm does it
81 ## automagicaly these days
82 ## Gziping the documentation files is not recomended - morcego
83 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
84
85 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
86
87 ## We need to change the man section internaly on the manpage
88 ## -- morcego (sugestion by Hal Burgiss)
89 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
90 sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{name}.1 > %{buildroot}%{_mandir}/man8/%{name}.8
91 cp -f *.action %{buildroot}%{ijbconf}/
92 cp -f re_filterfile %{buildroot}%{ijbconf}/re_filterfile
93 cp -f trust %{buildroot}%{ijbconf}/trust
94 cp -f templates/*  %{buildroot}%{ijbconf}/templates/
95 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
96 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
97 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
98
99 # verify all file locations, etc. in the config file
100 # don't start with ^ or commented lines are not replaced
101 ## Changing the sed paramter delimiter to @, so we don't have to
102 ## escape the slashes
103 cat config | \
104     sed 's@^confdir.*@confdir %{_sysconfdir}/%{name}@g' | \
105 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
106 #    sed 's/^re_filterfile.*/re_filterfile \/etc\/%{name}\/re_filterfile/g' | \
107 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
108 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
109 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
110 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
111     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
112     %{buildroot}%{ijbconf}/config
113 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' ijb.action >\
114     %{buildroot}%{ijbconf}/ijb.action
115
116 ## Macros are expanded even on commentaries. So, we have to use %%
117 ## -- morcego
118 #%%makeinstall
119
120 %pre
121 # We check to see if the user junkbuster exists.
122 # If it does, we do nothing
123 # If we don't, we check to see if the user junkbust exist and, in case it
124 # does, we change it do junkbuster. If it also does not exist, we create the
125 # junkbuster user -- morcego
126 id junkbuster > /dev/null 2>&1 
127 if [ $? -eq 1 ]; then
128         id junkbust > /dev/null 2>&1 
129         if [ $? -eq 0 ]; then
130                 /usr/sbin/usermod -l junkbuster -d %{_sysconfdir}/%{name} -s "" junkbust  > /dev/null 2>&1
131         else
132                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" junkbuster > /dev/null 2>&1 
133         fi
134 fi
135
136 %post
137 # for upgrade from 2.0.x
138 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
139  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
140 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
141 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
142 if [ "$1" = "1" ]; then
143      /sbin/chkconfig --add %{name}
144         /sbin/service %{name} condrestart > /dev/null 2>&1
145 fi
146 # 01/09/02 HB, getting rid of any user=junkbust
147 # Changed by morcego to use the id command.
148 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
149
150 %preun
151 if [ "$1" = "0" ]; then
152         /sbin/service %{name} stop > /dev/null 2>&1 ||:
153         /sbin/chkconfig --del %{name}
154 fi
155
156 %postun
157 #if [ "$1" -ge "1" ]; then
158 #       /sbin/service %{name} condrestart > /dev/null 2>&1
159 #fi
160 # dont forget to remove user and group junkbuster
161 id junkbuster > /dev/null 2>&1 && /usr/sbin/userdel junkbuster || /bin/true
162
163 %clean
164 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
165
166 %files
167 %defattr(0644,root,root,0755)
168 %doc README AUTHORS ChangeLog
169 # Where are the webserver/{developer,user}-manual files ?
170 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
171 %doc doc/webserver/developer-manual
172 %doc doc/webserver/user-manual
173 #%doc %{name}.weekly %{name}.monthly AUTHORS
174
175 %dir %{ijbconf}
176 %dir %{ijbconf}/templates
177 %attr(0744,junkbuster,junkbuster) %dir %{_localstatedir}/log/%{name}
178
179 %attr(0744,junkbuster,junkbuster)%{_sbindir}/%{name}
180
181 # We should not use wildchars here. This could mask missing files problems
182 # -- morcego
183 %config %{ijbconf}/config
184 %config %{ijbconf}/ijb-advanced.action
185 %config %{ijbconf}/ijb-basic.action
186 %config %{ijbconf}/ijb-intermediate.action
187 %config %{ijbconf}/ijb.action
188 %config %{ijbconf}/re_filterfile
189 %config %{ijbconf}/trust
190
191 %config %{ijbconf}/templates/blocked
192 %config %{ijbconf}/templates/blocked-compact
193 %config %{ijbconf}/templates/cgi-error-404
194 %config %{ijbconf}/templates/cgi-error-bad-param
195 %config %{ijbconf}/templates/cgi-error-disabled
196 %config %{ijbconf}/templates/cgi-error-file
197 %config %{ijbconf}/templates/cgi-error-modified
198 %config %{ijbconf}/templates/cgi-error-parse
199 %config %{ijbconf}/templates/connect-failed
200 %config %{ijbconf}/templates/default
201 %config %{ijbconf}/templates/edit-actions-add-url-form
202 %config %{ijbconf}/templates/edit-actions-for-url
203 %config %{ijbconf}/templates/edit-actions-list
204 %config %{ijbconf}/templates/edit-actions-list-section
205 %config %{ijbconf}/templates/edit-actions-list-url
206 %config %{ijbconf}/templates/edit-actions-remove-url-form
207 %config %{ijbconf}/templates/edit-actions-url-form
208 %config %{ijbconf}/templates/no-such-domain
209 %config %{ijbconf}/templates/show-request
210 %config %{ijbconf}/templates/show-status
211 %config %{ijbconf}/templates/show-status-file
212 %config %{ijbconf}/templates/show-url-info
213 %config %{ijbconf}/templates/show-version
214 %config %{ijbconf}/templates/toggle
215 %config %{ijbconf}/templates/toggle-mini
216 %config %{ijbconf}/templates/untrusted
217
218 %config %{_sysconfdir}/logrotate.d/%{name}
219 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
220
221 %{_mandir}/man8/%{name}.8*
222
223 %changelog
224 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
225 + junkbuster-2.9.11-8 
226 - Add --enable-no-gifs to configure.
227
228 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
229 + junkbuster-2.9.11-7
230 - Added BuildRequires to libtool.
231
232 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
233 + junkbuster-2.9.11-6
234 - Changed the routined that handle the junkbust and junkbuster users on
235   %%pre and %%post to work in a smoother manner
236 - %%files now uses hardcoded usernames, to avoid problems with package
237   name changes in the future
238
239 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
240 + junkbuster-2.9.11-5
241 - Added "make redhat-dok" to the build process
242 - Added docbook-utils to BuildRequires
243
244 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
245 + junkbuster-2.9.11-4
246 - Changing man section in the manpage from 1 to 8
247 - We now require packages, not files, to avoid issues with apt
248
249 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
250 + junkbuster-2.9.11-3
251 - Fixing permissions of the init script
252
253 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
254 + junkbuster-2.9.11-2
255 - General specfile fixup, using the best recomended practices, including:
256         - Adding -q to %%setup
257         - Using macros whereever possible
258         - Not using wildchars on %%files section
259         - Doubling the percentage char on changelog and comments, to
260           avoid rpm expanding them
261
262 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
263 - /bin/false for shell causes init script to fail. Reverting.
264
265 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
266 - Removed UID 73. Included user-manual and developer-manual in docs.
267   Include other actions files. Default shell is now /bin/false.
268   Userdel user=junkbust. ChangeLog was not zipped. Removed 
269   RPM_OPT_FLAGS kludge.
270
271 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
272 - add paranoia check for 'rm -rf %%{buildroot}'
273 - add gzip to 'BuildRequires'
274
275 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
276 - actionsfile is now ijb.action.
277
278 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
279 - Compress manpage
280 - Add more documents for installation
281 - Add version string to name and source
282
283 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
284 - Back to user 'junkbuster' and fix configure macro.
285
286 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
287 - More changes for user 'junkbust'. Init script had 'junkbuster'.
288
289 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
290 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
291 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
292
293 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
294 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
295 - made sure no default shell exists for user junkbust.
296
297 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
298 - rework of RPM
299
300 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
301 - CLF Logging patch by davep@cyw.uklinux.net
302 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
303
304 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
305 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
306 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
307   numerous fixes and enhancements for Steve's patch.
308 - adamlock@netscape.com (Adam Lock) in the windows version:
309   - Taskbar activity spinner always spins even when logging is
310   turned off (which is the default) - people who don't
311   like the spinner can turn it off from a menu option.
312   - Taskbar popup menu has a options submenu - people can now
313   open the settings files for cookies, blockers etc.
314   without opening the JB window.
315   - Logging functionality works again
316   - Buffer overflow is fixed - new code uses a bigger buffer
317   and snprintf so it shouldn't overflow anymore.
318 - Fixed userid swa, group learning problem while installing.
319   root must build RPM.
320 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
321   core dump when there is no log file.
322 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
323 - Fixed man page to include imagefile and popupfile.
324 - Sanity check for the statistics function added.
325 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
326  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
327  With IIS/5, it appears to omit the trailing \r\n from http header
328  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
329  responds with a HTTP 302 redirect header.  However, this header
330  message is missing the trailing \r\n.  IIS/5 then closes the
331  connection.  Junkbuster, unfortunately, discards the header becomes
332  it thinks it is incomplete - and it is.  MS have transmitted an
333  incomplete header!
334 - Added bug reports and patch submission forms in the docs.
335
336 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
337        Andrew <anw@tirana.freewire.co.uk> extended the JB:
338        Display of statistics of the total number of requests and the number
339        of requests filtered by junkbuster, also the percentage of requests
340        filtered. Suppression of the listing of files on the proxy-args page.
341        All stuff optional and configurable.
342
343 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
344        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
345        code which prevented the JB from handling URLs of the form
346        user:password@www.foo.com. Fixed.
347
348 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
349         Blank images are no longer cached, thanks to a hint from Markus 
350         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
351         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
352         on the correct browser version nowadays. Incorporated many 
353         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
354         spec file. Fixed logging problem and since runlevel 2 does not 
355         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
356         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
357         <walker@netgate.net>. You should now be able to build this RPM as 
358         a non-root user (mathias@weidner.sem.lipsia.de).
359
360 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
361         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
362         to allow more sophisticated matching of blocked images. Logrotate
363         logfile. Added files for auto-updating the blocklist et al.
364
365 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
366         Configure blank version via config file. No separate blank
367         version anymore. Added Roland's <roland@spinnaker.rhein.de>
368         patch to show a logo instead of a blank area. Added a suggestion
369         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
370         More regexps in the blocklist. Prepared the forwardfile for
371         squid. Extended image regexp with help from gabriel 
372         <somlo@CS.ColoState.EDU>.
373
374 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
375         All RPMs now identify themselves in the show-proxy-args page.
376         Released Windoze version. Run junkbuster as nobody instead of
377         root. 
378
379 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
380         Newest version. First release (hence the little version number
381         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
382         security over 2.0.1; some multi-user sites will need to change 
383         the listen-address in the configuration file. The blank version of
384         the Internet Junkbuster has a more sophisticated way of replacing
385         images. All RPMs identify themselves in the show-proxy-args page.
386
387 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
388         Modified the blocking feature, so that only GIFs and JPEGs are
389         blocked and replaced but not HTML pages. Thanks to 
390         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
391         idea. Added numerous stuff to the blocklist. Keep patches in
392         seperate files and no longer in diffs (easier to maintain).
393
394 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
395         Moved config files to /etc/junkbuster directory, moved man page,
396         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
397         Made new version junkbuster-raw (which is only a stripped version of 
398         the junkuster rpm, i.e. without my blocklist, etc.)
399
400 * Tue Jun 16 1998 (2.0-1)
401         Uhm, not that much. Just a new junkbuster version that
402         fixes a couple of bugs ... and of course a bigger 
403         blocklist with the unique Now-less-ads-than-ever(SM)
404         feature.
405         Oh, one thing: I changed the default user agent to Linux -- no 
406         need anymore to support Apple.
407
408 * Tue Jun 16 1998 (2.0-0)
409         Now-less-ads-than-ever (SM)
410         compiled with gcc instead of cc
411         compiled with -O3, thus it should be a little faster
412         show-proxy-args now works
413         /etc/junkbuster.init wasn't necessary
414
415 * Tue Jun 16 1998 (1.4)
416         some more config files were put into /etc
417         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
418         displayed by Netscape instead of the blocked image.
419         Read http://www.waldherr.org/junkbuster/ for
420         further info.
421
422 * Tue Jun 16 1998 (1.3)
423         The program has been moved to /usr/sbin (from /usr/local/bin)
424         Init- and stopscripts (/etc/rc.d/rc*) have been added so
425         that the junkbuster starts automatically during bootup.
426         The /etc/blocklist file is much more sophisticated. Theoretically
427         one should e.g. browse all major US and German newspapers without
428         seeing one annoying ad.
429         junkbuster.init was modified. It now starts junkbuster with an
430         additional "-r @" flag.
431
432 # $Log: junkbuster-rh.spec,v $
433 # Revision 1.39  2002/03/08 18:57:29  swa
434 # remove user junkbuster after de-installation.
435 #
436 # Revision 1.38  2002/03/08 13:45:27  morcego
437 # Adding libtool to Buildrequires
438 #
439 # Revision 1.37  2002/03/07 19:23:49  swa
440 # i hate to scroll. suse: wrong configdir.
441 #
442 # Revision 1.36  2002/03/07 05:06:54  morcego
443 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
444 #
445 # Revision 1.34  2002/03/07 00:11:57  morcego
446 # Few changes on the %pre and %post sections of the rh specfile to handle
447 # usernames more cleanly
448 #
449 # Revision 1.33  2002/03/05 13:13:57  morcego
450 # - Added "make redhat-dok" to the build phase
451 # - Added docbook-utils to BuildRequires
452 #
453 # Revision 1.32  2002/03/05 12:34:24  morcego
454 # - Changing section internaly on the manpage from 1 to 8
455 # - We now require packages, not files, to avoid issues with apt
456 #
457 # Revision 1.31  2002/03/04 18:06:09  morcego
458 # SPECFILE: fixing permissing of the init script (broken by the last change)
459 #
460 # Revision 1.30  2002/03/04 16:18:03  morcego
461 # General cleanup of the rh specfile.
462 #
463 # %changelog
464 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
465 # + junkbuster-2.9.11-2
466 # - General specfile fixup, using the best recomended practices, including:
467 #         - Adding -q to %%setup
468 #         - Using macros whereever possible
469 #         - Not using wildchars on %%files section
470 #         - Doubling the percentage char on changelog and comments, to
471 #           avoid rpm expanding them
472 #
473 # Revision 1.29  2002/03/03 19:21:22  hal9
474 # Init script fails if shell is /bin/false.
475 #
476 # Revision 1.28  2002/01/09 18:34:03  hal9
477 # nit.
478 #
479 # Revision 1.27  2002/01/09 18:32:02  hal9
480 # Removed RPM_OPT_FLAGS kludge.
481 #
482 # Revision 1.26  2002/01/09 18:21:10  hal9
483 # A few minor updates.
484 #
485 # Revision 1.25  2001/12/28 01:45:36  steudten
486 # Add paranoia check and BuildReq: gzip
487 #
488 # Revision 1.24  2001/12/01 21:43:14  hal9
489 # Allowed for new ijb.action file.
490 #
491 # Revision 1.23  2001/11/06 12:09:03  steudten
492 # Compress doc files. Install README and AUTHORS at last as document.
493 #
494 # Revision 1.22  2001/11/05 21:37:34  steudten
495 # Fix to include the actual version for name.
496 # Let the 'real' packager be included - sorry stefan.
497 #
498 # Revision 1.21  2001/10/31 19:27:27  swa
499 # consistent description. new name for suse since
500 # we had troubles with rpms of identical names
501 # on the webserver.
502 #
503 # Revision 1.20  2001/10/24 15:45:49  hal9
504 # To keep Thomas happy (aka correcting my  mistakes)
505 #
506 # Revision 1.19  2001/10/15 03:23:59  hal9
507 # Nits.
508 #
509 # Revision 1.17  2001/10/10 18:59:28  hal9
510 # Minor change for init script.
511 #
512 # Revision 1.16  2001/09/24 20:56:23  hal9
513 # Minor changes.
514 #
515 # Revision 1.13  2001/09/10 17:44:43  swa
516 # integrate three pieces of documentation. needs work.
517 # will not build cleanly under redhat.
518 #
519 # Revision 1.12  2001/09/10 16:25:04  swa
520 # copy all templates. version updated.
521 #
522 # Revision 1.11  2001/07/03 11:00:25  sarantis
523 # replaced permissionsfile with actionsfile
524 #
525 # Revision 1.10  2001/07/03 09:34:44  sarantis
526 # bumped up version number.
527 #
528 # Revision 1.9  2001/06/12 18:15:29  swa
529 # the %% in front of configure (see tag below) confused
530 # the rpm build process on 7.1.
531 #
532 # Revision 1.8  2001/06/12 17:15:56  swa
533 # fixes, because a clean build on rh6.1 was impossible.
534 # GZIP confuses make, %% configure confuses rpm, etc.
535 #
536 # Revision 1.7  2001/06/11 12:17:26  sarantis
537 # fix typo in %%post
538 #
539 # Revision 1.6  2001/06/11 11:28:25  sarantis
540 # Further optimizations and adaptations in the spec file.
541 #
542 # Revision 1.5  2001/06/09 09:14:11  swa
543 # shamelessly adapted RPM stuff from the newest rpm that
544 # RedHat provided for the JB.
545 #
546 # Revision 1.4  2001/06/08 20:54:18  swa
547 # type with status file. remove forward et. al from file list.
548 #
549 # Revision 1.3  2001/06/07 17:28:10  swa
550 # cosmetics
551 #
552 # Revision 1.2  2001/06/04 18:31:58  swa
553 # files are now prefixed with either `confdir' or `logdir'.
554 # `make redhat-dist' replaces both entries confdir and logdir
555 # with redhat values
556 #
557 # Revision 1.1  2001/06/04 10:44:57  swa
558 # `make redhatr-dist' now works. Except for the paths
559 # in the config file.
560 #
561 #
562 #