- Assorted refinements, optimizations and fixes in the js-annoyances,
[privoxy.git] / privoxy-rh.spec
index d23de60..1ee5b2e 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: privoxy-rh.spec,v 1.33.2.9 2002/07/05 17:16:19 morcego Exp $
+# $Id: privoxy-rh.spec,v 1.33.2.18 2002/08/10 11:28:50 oes Exp $
 #
 # Written by and Copyright (C) 2001 the SourceForge
 # Privoxy team. http://www.privoxy.org/
@@ -37,8 +37,8 @@ Name: privoxy
 # ATTENTION
 # Version and release should be updated acordingly on configure.in and
 # configure. Otherwise, the package can be build with the wrong value
-Version: 2.9.15
-Release: 8
+Version: 3.0.0
+Release: 1
 Summary: Privoxy - privacy enhancing proxy
 License: GPL
 Source0: http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
@@ -67,9 +67,9 @@ Privoxy is based on the Internet Junkbuster.
 %build
 
 # We check to see if versions match
-VERSION_MAJOR=2
-VERSION_MINOR=9
-VERSION_POINT=15
+VERSION_MAJOR=3
+VERSION_MINOR=0
+VERSION_POINT=0
 
 CONFIG_VERSION=`cat configure.in | sed -n -e 's/^VERSION_MAJOR=\([0-9]*\)/\1./p' -e 's/^VERSION_MINOR=\([0-9]*\)/\1./p' -e 's/^VERSION_POINT=\([0-9]*\)/\1/p' | awk '{printf $1}'`
 if [ "%{version}" != "${CONFIG_VERSION}" ]; then
@@ -206,15 +206,17 @@ fi
 
 %post
 # for upgrade from 2.0.x
-[ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
- mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
-[ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
- mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
-chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
-chown -R %{name}:%{name} %{_sysconfdir}/%{name} 2>/dev/null
+[ -f %{_localstatedir}/log/%{oldname}/logfile ] && {
+  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile ||: ;
+  chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null ||: ;
+}
+[ -f %{_localstatedir}/log/%{name}/%{name} ] && {
+  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile ||: ;
+  chown -R %{name}:%{name} %{_sysconfdir}/%{name} 2>/dev/null ||: ;
+}
 /sbin/chkconfig --add privoxy
 if [ "$1" = "1" ]; then
-       /sbin/service %{name} condrestart > /dev/null 2>&1
+       /sbin/service %{name} condrestart > /dev/null 2>&1 ||:
 fi
 
 %preun
@@ -310,11 +312,23 @@ fi
 %defattr(0644,root,root,0755)
 
 %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
-%config(noreplace) %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
+%config(noreplace) %attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
 
 %{_mandir}/man1/%{name}.*
 
 %changelog
+* Tue Aug 25 2002 Hal Burgiss <hal@foobox.net>
+- Bump version for 3.0.0 :)
+
+* Tue Aug 06 2002 Hal Burgiss <hal@foobox.net>
+- Reset version for 2.9.20.
+
+* Tue Jul 30 2002 Hal Burgiss <hal@foobox.net>
+- Reset version for 2.9.18.
+
+* Sat Jul 27 2002 Hal Burgiss <hal@foobox.net>
+- Reset version and release for 2.9.16.
+
 * Fri Jul 12 2002 Karsten Hopp <karsten@redhat.de>
 - don't use ghost files for rcX.d/*, using chkconfig is the 
   correct way to do this job (#68619)
@@ -714,6 +728,33 @@ fi
        additional "-r @" flag.
 
 # $Log: privoxy-rh.spec,v $
+# Revision 1.33.2.18  2002/08/10 11:28:50  oes
+# Bumped version
+#
+# Revision 1.33.2.17  2002/08/07 01:08:49  hal9
+# Bumped version to 2.9.18.
+#
+# Revision 1.33.2.16  2002/08/05 08:42:13  kick_
+# same permissions, same runlevels as all the other initscripts
+#
+# Revision 1.33.2.15  2002/07/30 21:51:19  hal9
+# Bump version to 2.9.17.
+#
+# Revision 1.33.2.14  2002/07/27 21:58:16  kick_
+# bump version
+#
+# Revision 1.33.2.13  2002/07/27 21:39:41  kick_
+# condrestart raised an error during an fresh install when privoxy wasn't already running
+#
+# Revision 1.33.2.12  2002/07/27 15:47:10  hal9
+# Reset version and release for 2.9.16.
+#
+# Revision 1.33.2.11  2002/07/25 09:47:57  kick_
+# this caused some errors during a fresh installation. It's unnecessary to call an extra program (/bin/true) to set the error code to 0
+#
+# Revision 1.33.2.10  2002/07/12 09:14:26  kick_
+# don't use ghost files for rcX.d/*, chkconfig is available to do this job. Enable translation of error messge
+#
 # Revision 1.33.2.9  2002/07/05 17:16:19  morcego
 # - Changing delete order for groups and users (users should be first)
 #