820f3f2ce1630e5cd0f35f44d1994a17c9ac0c9a
[privoxy.git] / privoxy-suse.spec
1 # $Id: privoxy-suse.spec,v 1.20.2.2 2002/05/28 02:39:38 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public 
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # do not set to %{name}
30 %define privoxyconf %{_sysconfdir}/privoxy
31 %define privoxy_uid 73
32 %define privoxy_gid 73
33
34
35 Summary:      Privoxy - privacy enhancing proxy
36 Vendor:       Privoxy.Org
37 Name:         privoxy-suse
38 Distribution: defineme
39 Version: 2.9.16
40 Release: 1
41 # Needs makefile change: Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}-%{status}-src.tar.gz
42 Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}.tar.gz
43 # not sure if this works
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Packager:     Stefan Waldherr <stefan@waldherr.org>
46 License:     GPL
47 Group:        Networking/Utilities
48 URL:          http://www.privoxy.org/
49 Autoreqprov:  on
50 BuildRequires: perl gzip libtool autoconf
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster-suse junkbuster privoxy
52
53 #
54 # -----------------------------------------------------------------------------
55 #
56 %description
57 Privoxy is a web proxy with advanced filtering capabilities for
58 protecting privacy, filtering web page content, managing cookies,
59 controlling access, and removing ads, banners, pop-ups and other
60 obnoxious Internet junk. Privoxy has a very flexible configuration and
61 can be customized to suit individual needs and tastes. Privoxy has 
62 application for both stand-alone systems and multi-user networks.
63
64 Privoxy is based on the  Internet Junkbuster.
65
66 Authors:
67 --------
68     http://www.privoxy.org/
69
70 SuSE series: n
71
72 #
73 # -----------------------------------------------------------------------------
74 #
75 %prep
76 %setup -c
77
78 #
79 # -----------------------------------------------------------------------------
80 #
81 %build
82 autoheader
83 autoconf
84 ./configure --disable-dynamic-pcre
85 make
86
87
88 ## Explicitily stripping is not recomended.
89 ## This is handled altomaticaly by RPM, and can couse troubles if
90 ## anyone wants to build an unstriped version - morcego
91 #strip privoxy
92
93 #
94 # -----------------------------------------------------------------------------
95 #
96 %install
97 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
98 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
99          ${RPM_BUILD_ROOT}%{_mandir}/man8 \
100          ${RPM_BUILD_ROOT}/var/log/privoxy \
101          ${RPM_BUILD_ROOT}%{privoxyconf}/templates \
102          ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
103          ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
104 gzip README AUTHORS ChangeLog privoxy.1 LICENSE || /bin/true
105 install -s -m 744 privoxy $RPM_BUILD_ROOT%{_sbindir}/privoxy
106 cp -f privoxy.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/privoxy.8.gz
107 cp -f *.action $RPM_BUILD_ROOT%{privoxyconf}/
108 cp -f default.filter $RPM_BUILD_ROOT%{privoxyconf}/default.filter
109 cp -f trust $RPM_BUILD_ROOT%{privoxyconf}/trust
110 cp -f templates/*  $RPM_BUILD_ROOT%{privoxyconf}/templates/
111 cp -f privoxy.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/privoxy
112 install -m 755 privoxy.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/privoxy
113 install -m 711 -d $RPM_BUILD_ROOT/var/log/privoxy
114 ln -sf /etc/init.d/privoxy $RPM_BUILD_ROOT/usr/sbin/rcprivoxy
115
116 # verify all file locations, etc. in the config file
117 # don't start with ^ or commented lines are not replaced
118 cat config | \
119     sed 's/^confdir.*/confdir \/etc\/privoxy/g' | \
120 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/privoxy\/permissionsfile/g' | \
121 #    sed 's/^filterfile.*/default.filter \/etc\/privoxy\/default.filter/g' | \
122 #    sed 's/^logfile.*/logfile \/var\/log\/privoxy\/logfile/g' | \
123 #    sed 's/^jarfile.*/jarfile \/var\/log\/privoxy\/jarfile/g' | \
124 #    sed 's/^forward.*/forward \/etc\/privoxy\/forward/g' | \
125 #    sed 's/^aclfile.*/aclfile \/etc\/privoxy\/aclfile/g' > \
126     sed 's/^logdir.*/logdir \/var\/log\/privoxy/g' > \
127     $RPM_BUILD_ROOT%{privoxyconf}/config
128
129 #
130 # -----------------------------------------------------------------------------
131 #
132 %pre
133 # We check to see if the user privoxy exists.
134 # If it does, we do nothing
135 # If we don't, we check to see if the user junkbust exist and, in case it
136 # does, we change it do privoxy. If it also does not exist, we create the
137 # privoxy user -- morcego
138 id privoxy > /dev/null 2>&1 
139 if [ $? -eq 1 ]; then
140         id junkbust > /dev/null 2>&1 
141         if [ $? -eq 0 ]; then
142                 /usr/sbin/usermod -u %{privoxy_uid} -g %{privoxy_gid} -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust  > /dev/null 2>&1
143         else
144 # -r does not work on suse.
145                 /usr/sbin/groupadd -g %{privoxy_gid} privoxy
146                 /usr/sbin/useradd -u %{privoxy_uid} -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1 
147         fi
148 fi
149
150 #
151 # -----------------------------------------------------------------------------
152 #
153 %post
154 [ -f /var/log/privoxy/privoxy ] &&\
155  mv -f /var/log/privoxy/privoxy /var/log/privoxy/logfile || /bin/true
156 chown -R privoxy:privoxy /var/log/privoxy 2>/dev/null
157 chown -R privoxy:privoxy /etc/privoxy 2>/dev/null
158 # not available on suse
159 #if [ "$1" = "1" ]; then
160 #     /sbin/chkconfig --add privoxy
161 #       /sbin/service privoxy condrestart > /dev/null 2>&1
162 #fi
163 # 01/09/02 HB, getting rid of any user=junkbust
164 # Changed by morcego to use the id command.
165 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
166 sbin/insserv etc/init.d/privoxy
167
168 #
169 # -----------------------------------------------------------------------------
170 #
171 %preun
172 # need to stop the service on suse. swa.
173 #if [ "$1" = "0" ]; then
174 #       /sbin/service privoxy stop > /dev/null 2>&1 ||:
175 #fi
176
177 #
178 # -----------------------------------------------------------------------------
179 #
180 %postun
181 sbin/insserv etc/init.d/
182 # dont forget to remove user and group privoxy
183 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
184
185 #
186 # -----------------------------------------------------------------------------
187 #
188 %clean
189 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
190
191 #
192 # -----------------------------------------------------------------------------
193 #
194 %files
195 %defattr(-,root,root)
196 %doc README.gz AUTHORS.gz ChangeLog.gz LICENSE.gz
197 %doc doc/webserver/developer-manual
198 %doc doc/webserver/user-manual
199 %doc doc/webserver/faq
200 %doc doc/webserver/p_doc.css
201 %doc doc/webserver/p_web.css
202 %doc doc/webserver/privoxy-index.html
203 %doc doc/webserver/images
204 %doc doc/webserver/man-page
205
206 #%doc privoxy.weekly privoxy.monthly AUTHORS
207 %dir %{privoxyconf}
208 %config %{privoxyconf}/*
209 %attr(0744,privoxy,privoxy) %dir /var/log/privoxy
210 %config %{_sysconfdir}/logrotate.d/privoxy
211 %attr(0755,root,root)/usr/sbin/privoxy
212 %{_mandir}/man8/*
213 %config %{_sysconfdir}/init.d/privoxy
214 /usr/sbin/rcprivoxy
215
216 #
217 # -----------------------------------------------------------------------------
218 #
219 %changelog
220 * Sat Jul 27 2002 Hal Burgiss <hal@foobox.net>
221 - Reset version and release for 2.9.16.
222
223 * Mon May 27 2002 Hal Burgiss <hal@foobox.net>
224 + privoxy-2.9.15-1
225 - Index.html is now privoxy-index.html for doc usage.
226
227 * Sat May 25 2002 Hal Burgiss <hal@foobox.net>
228 + privoxy-2.9.15-1
229 - Add html man page so index.html does not 404.
230
231 * Fri May 24 2002 Hal Burgiss <hal@foobox.net>
232 + privoxy-2.9.15-1
233 - Add doc/images directory.
234
235 * Fri May 03 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
236 + privoxy-suse-2.9.15-1
237 - Version bump
238
239 * Fri Apr 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
240 + privoxy-suse-2.9.14-3
241 - Changing Vendor to Privoxy.Org
242
243 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
244 + privoxy-suse-2.9.14-2
245 - Bumping release to reflect the new value on configure.in
246 - Taking the oportunity to change the header Copyright to License. The
247   Copyright headers is deprecated, and after all, GPL is a license, not a
248   Copyright
249
250 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
251 + privoxy-2.9.13-4
252 - Add LICENSE.gz, p_web.css, and index.html. Add autoconf
253 - to Buildrequires.
254
255 * Wed Mar 27 2002 Hal Burgiss <hal@foobox.net>
256 + privoxy-2.9.13-3
257 - Doc css has changed names.
258
259 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
260 + privoxy-2.9.13-3
261 - Minor fix to description.
262
263 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
264 - added faq to docs.
265
266 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
267 - added ijb_docs.css to docs.
268
269 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
270 - Remove --enable-no-gifs from configure.
271
272 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
273 - /bin/false for shell causes init script to fail. Reverting.
274
275 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
276 - Removed UID 73. Included user-manual and developer-manual in docs.
277   Include other actions files. Default shell is now /bin/false.
278   Userdel user=junkbust. ChangeLog was not zipped. Removed
279   RPM_OPT_FLAGS kludge.
280
281 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
282 - add paranoia check for 'rm -rf $RPM_BUILD_ROOT'
283 - add gzip to 'BuildRequires'
284
285 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
286 - actionsfile is now ijb.action.
287
288 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
289 - Compress manpage
290 - Add more documents for installation
291 - Add version string to name and source
292
293 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
294 - Back to user 'junkbuster' and fix configure macro.
295
296 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
297 - More changes for user 'junkbust'. Init script had 'junkbuster'.
298
299 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
300 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
301 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
302
303 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
304 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and
305 - made sure no default shell exists for user junkbust.
306
307 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
308 - rework of RPM
309 * Wed Feb 14 2001 - uli@suse.de
310 - fixed init script
311 * Wed Dec 06 2000 - bjacke@suse.de
312 - renamed package to junkbuster
313 - fixed copyright tag
314 * Thu Nov 30 2000 - uli@suse.de
315 - moved init script to /etc/init.d
316 * Wed Feb 16 2000 - kukuk@suse.de
317 - Move /usr/man -> /usr/share/man
318 - Mark /etc/ijb as "config(noreplace)"
319 * Mon Sep 20 1999 - uli@suse.de
320 - fixed init script
321 * Mon Sep 13 1999 - bs@suse.de
322 - ran old prepare_spec on spec file to switch to new prepare_spec.
323 * Thu Apr 01 1999 - daniel@suse.de
324 - do not start ijb as root (security)
325 * Tue Mar 30 1999 - daniel@suse.de
326 - donĀ“t use saclfile.ini
327 * Tue Mar 30 1999 - daniel@suse.de
328 - small fix to whitelist-configuration,
329   version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
330   (http://www.waldherr.org/junkbuster/)
331 * Mon Mar 01 1999 - daniel@suse.de
332 - new package: version 2.0
333
334 # $Log: privoxy-suse.spec,v $
335 # Revision 1.20.2.2  2002/05/28 02:39:38  hal9
336 # Replace index.html with privoxy-index.html for docs.
337 #
338 # Revision 1.20.2.1  2002/05/26 17:20:23  hal9
339 # Add images to doc dirs.
340 #
341 # Revision 1.20  2002/05/25 02:08:23  hal9
342 # Add doc/images directory.
343 # Redhat: alphabetized list of templates (and I think added one in the process)
344 #
345 # Revision 1.19  2002/05/03 17:14:36  morcego
346 # *.spec: Version bump to 2.9.15
347 # -rh.spec: noreplace for %%{privoxyconf}/config
348 #           Will interrupt the build if versions from configure.in and
349 #               specfile do not match
350 #
351 # Revision 1.18  2002/04/27 20:26:59  swa
352 # uid, gui 73 incorporated
353 #
354 # Revision 1.17  2002/04/26 15:51:05  morcego
355 # Changing Vendor value to Privoxy.Org
356 #
357 # Revision 1.16  2002/04/22 16:32:31  morcego
358 # configure.in, *.spec: Bumping release to 2 (2.9.14-2)
359 # -rh.spec: uid and gid are now macros
360 # -suse.spec: Changing the header Copyright to License (Copyright is
361 #             deprecable)
362 #
363 # Revision 1.15  2002/04/16 18:49:07  oes
364 # Build with static built-in pcre
365 #
366 # Revision 1.14  2002/04/11 17:57:40  oes
367 # Fixed(?) Conflicts: Provides: Obsoletes:
368 #
369 # Revision 1.13  2002/04/11 10:09:20  oes
370 # Version 2.9.14
371 #
372 # Revision 1.12  2002/04/09 13:29:43  swa
373 # build suse and gen-dist with html docs. do not generate docs while building rpm
374 #
375 # Revision 1.11  2002/04/09 03:12:37  hal9
376 # Add LICENSE, p_web.css and index.html. Add autoconf to buildrequires.
377 #
378 # Revision 1.10  2002/04/08 20:24:13  swa
379 # fixed JB spelling
380 #
381 # Revision 1.9  2002/03/30 09:01:52  swa
382 # new release
383 #
384 # Revision 1.8  2002/03/27 23:46:41  hal9
385 # ijb_docs.css to p_doc.css
386 #
387 # Revision 1.7  2002/03/27 00:49:39  hal9
388 # Minor fix to description.
389 #
390 # Revision 1.6  2002/03/26 22:29:55  swa
391 # we have a new homepage!
392 #
393 # Revision 1.5  2002/03/25 03:10:50  hal9
394 # Added faq to docs.
395 #
396 # Revision 1.4  2002/03/24 12:56:21  swa
397 # name change related issues.
398 #
399 # Revision 1.3  2002/03/24 12:44:31  swa
400 # new version string
401 #
402 # Revision 1.2  2002/03/24 11:40:14  swa
403 # name change
404 #
405 # Revision 1.1  2002/03/24 11:23:44  swa
406 # name change
407 #
408 # Revision 1.21  2002/03/21 16:04:33  hal9
409 # added ijb_docs.css to %%doc
410 #
411 # Revision 1.20  2002/03/12 13:42:14  sarantis
412 # remove hardcoded "ijbswa" from build phase
413 #
414 # Revision 1.19  2002/03/11 22:59:05  hal9
415 # Remove --enable-no-gifs
416 #
417 # Revision 1.18  2002/03/11 12:30:31  swa
418 # be consistent with rh spec file
419 #
420 # Revision 1.17  2002/03/08 19:30:23  swa
421 # remove user junkbuster after de-installation.
422 # synced suse with rh-specfile. installation
423 # and de-installation seem to work.
424 #
425 # Revision 1.16  2002/03/08 18:40:44  swa
426 # build requires tools. useradd and del works
427 # now.
428 #
429 # Revision 1.15  2002/03/07 19:23:50  swa
430 # i hate to scroll. suse: wrong configdir.
431 #
432 # Revision 1.14  2002/03/07 19:10:21  swa
433 # builds cleanly. thanks to kukuk@suse.de
434 # not yet tested.
435 #
436 # Revision 1.13  2002/03/07 18:25:56  swa
437 # synced redhat and suse build process
438 #
439 # Revision 1.12  2002/03/02 15:50:04  swa
440 # 2.9.11 version. more input for docs.
441 #
442 # Revision 1.11  2001/12/02 10:29:26  swa
443 # New version made these changes necessary.
444 #
445 # Revision 1.10  2001/10/31 19:27:27  swa
446 # consistent description. new name for suse since
447 # we had troubles with rpms of identical names
448 # on the webserver.
449 #
450 # Revision 1.9  2001/10/26 18:17:23  swa
451 # new version string
452 #
453 # Revision 1.8  2001/09/13 16:22:42  swa
454 # man page is legacy. suse rpm now contains html
455 # documentation.
456 #
457 # Revision 1.7  2001/09/10 17:44:22  swa
458 # integrate three pieces of documentation.
459 #
460 # Revision 1.6  2001/09/10 16:29:23  swa
461 # binary contained debug info.
462 # buildroot definition fucks up the build process under suse.
463 # program needs to write in varlogjunkbuster
464 # install all templates
465 # create varlogjunkbuster
466 #
467 # Revision 1.5  2001/06/09 09:13:29  swa
468 # description shorter
469 #
470 # Revision 1.4  2001/06/08 20:53:36  swa
471 # use buildroot, export init to separate file (better manageability)
472 #
473 # Revision 1.3  2001/06/07 17:28:10  swa
474 # cosmetics
475 #
476 # Revision 1.2  2001/06/07 17:18:44  swa
477 # header fixed
478 #
479 #