47a1962fb1c1421b5453adc26ea9770da513efd0
[privoxy.git] / privoxy-rh.spec
1 # $Id: privoxy-rh.spec,v 1.7 2002/03/24 21:07:18 hal9 Exp $
2 #
3 # Written by and Copyright (C) 2001 the SourceForge
4 # PRIVOXY team.  http://ijbswa.sourceforge.net
5 #
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and 
8 # Junkbusters Corporation.  http://www.junkbusters.com
9 #
10 # This program is free software; you can redistribute it 
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
15 #
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE.  See the GNU General Public
20 # License for more details.
21 #
22 # The GNU General Public License should be included with
23 # this file.  If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA  02111-1307, USA.
27 #
28
29 # Defines should happen in the begining of the file
30 %define oldname junkbuster
31 %define privoxyconf %{_sysconfdir}/%{name}
32
33 Summary: Privoxy - privacy enhancing proxy
34 Vendor: http://ijbswa.sourceforge.net
35 Name: privoxy
36 Version: 2.9.13
37 Release: 1
38 Source0: http://www.waldherr.org/%{name}/privoxy-%{version}.tar.gz
39 License: GPL
40 BuildRoot: %{_tmppath}/%{name}-%{version}-root
41 Group: Networking/Utilities
42 URL: http://ijbswa.sourceforge.net/
43 Obsoletes: junkbuster-raw junkbuster-blank junkbuster
44 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service 
45 Prereq: shadow-utils, chkconfig, initscripts, sh-utils
46 BuildRequires: perl gzip sed docbook-utils libtool autoconf
47 Conflicts: junkbuster-raw junkbuster-blank junkbuster
48
49 %description 
50 Privoxy is a web proxy with advanced filtering capabilities for
51 protecting privacy, filtering web page content, managing cookies,
52 controlling access, and removing ads, banners, pop-ups and other
53 obnoxious Internet junk. Privoxy has a very flexible configuration and
54 can be customized to suit individual needs and tastes. Internet
55 Privoxy has application for both stand-alone systems and multi-user
56 networks.
57
58 Privoxy is based on the code of the Internet Junkbuster. Junkbuster
59 was originally written by JunkBusters Corporation, and was released as
60 free open-source software under the GNU GPL. Stefan Waldherr made many
61 improvements, and started the SourceForge project to continue
62 development. Several other developers are now contributing.
63
64 %prep
65 %setup -q -c
66
67 %build
68 echo This specfile is broken. Please, wait while we fix it
69 echo == morcego
70 exit 1
71 autoheader
72 autoconf
73 %configure
74 make 
75 make redhat-dok
76
77 ## Explicitily stripping is not recomended.
78 ## This is handled altomaticaly by RPM, and can couse troubles if
79 ## anyone wants to build an unstriped version - morcego
80 #strip %{name}
81
82 %install
83 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
84 mkdir -p %{buildroot}%{_sbindir} \
85          %{buildroot}%{_mandir}/man1 \
86          %{buildroot}%{_localstatedir}/log/%{name} \
87          %{buildroot}%{privoxyconf}/templates \
88          %{buildroot}%{_sysconfdir}/logrotate.d \
89          %{buildroot}%{_sysconfdir}/rc.d/init.d 
90
91 ## Manual gziping of manpages should not be done, once it can
92 ## break the building on some distributions. Anyway, rpm does it
93 ## automagicaly these days
94 ## Gziping the documentation files is not recomended - morcego
95 #gzip README AUTHORS ChangeLog %{name}.1 || /bin/true
96
97 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
98
99 ## We need to change the man section internaly on the manpage
100 ## -- morcego (sugestion by Hal Burgiss)
101 #cp -f %{name}.1 %{buildroot}%{_mandir}/man8/%{name}.8
102
103 # do we need this???
104 #sed -e 's@^.TH JUNKBUSTER 1@.TH JUNKBUSTER 8@g' %{oldname}.1 > %{buildroot}%{_mandir}/man8/%{oldname}.8
105 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
106 cp -f *.action %{buildroot}%{privoxyconf}/
107 cp -f default.filter %{buildroot}%{privoxyconf}/default.filter
108 cp -f trust %{buildroot}%{privoxyconf}/trust
109 cp -f templates/*  %{buildroot}%{privoxyconf}/templates/
110 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
111 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
112 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
113
114 # verify all file locations, etc. in the config file
115 # don't start with ^ or commented lines are not replaced
116 ## Changing the sed paramter delimiter to @, so we don't have to
117 ## escape the slashes
118 cat config | \
119     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
120 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
121 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
122 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
123 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
124 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
125 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
126     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' > \
127     %{buildroot}%{privoxyconf}/config
128 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
129     %{buildroot}%{privoxyconf}/default.action
130
131 ## Macros are expanded even on commentaries. So, we have to use %%
132 ## -- morcego
133 #%%makeinstall
134
135 %pre
136 # We check to see if the user privoxy exists.
137 # If it does, we do nothing
138 # If we don't, we check to see if the user junkbust exist and, in case it
139 # does, we change it do junkbuster. If it also does not exist, we create the
140 # privoxy user -- morcego
141 id privoxy > /dev/null 2>&1 
142 if [ $? -eq 1 ]; then
143         id privoxy > /dev/null 2>&1 
144         if [ $? -eq 0 ]; then
145                 /usr/sbin/usermod -l privoxy -d %{_sysconfdir}/%{name} -s "" privoxy  > /dev/null 2>&1
146         else
147                 /usr/sbin/useradd -d %{_sysconfdir}/%{name} -r -s "" privoxy > /dev/null 2>&1 
148         fi
149 fi
150
151 %post
152 # for upgrade from 2.0.x
153 [ -f %{_localstatedir}/log/%{oldname}/logfile ] &&\
154  mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile || /bin/true
155 [ -f %{_localstatedir}/log/%{name}/%{name} ] &&\
156  mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile || /bin/true
157 chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null
158 chown -R %{name}:%{name} /etc/%{name} 2>/dev/null
159 if [ "$1" = "1" ]; then
160 #     /sbin/chkconfig --add %{name}
161         /sbin/service %{name} condrestart > /dev/null 2>&1
162 fi
163 # 01/09/02 HB, getting rid of any user=junkbust
164 # Changed by morcego to use the id command.
165 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
166
167 %preun
168 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
169 /sbin/chkconfig --del %{oldname} ||:
170
171 if [ "$1" = "0" ]; then
172         /sbin/service %{name} stop > /dev/null 2>&1 ||:
173 fi
174
175 %postun
176 #if [ "$1" -ge "1" ]; then
177 #       /sbin/service %{name} condrestart > /dev/null 2>&1
178 #fi
179 # dont forget to remove user and group privoxy
180 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
181
182 %clean
183 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
184
185 %files
186 %defattr(0644,root,root,0755)
187 %doc README AUTHORS ChangeLog
188 %doc doc/text/developer-manual.txt doc/text/user-manual.txt
189 %doc doc/webserver/developer-manual
190 %doc doc/webserver/user-manual
191 %doc doc/webserver/ijb_docs.css
192 #%doc %{name}.weekly %{name}.monthly AUTHORS
193
194 %dir %{privoxyconf}
195 %dir %{privoxyconf}/templates
196 %attr(0744,privoxy,privoxy) %dir %{_localstatedir}/log/%{name}
197
198 %attr(0744,privoxy,privoxy)%{_sbindir}/%{name}
199
200 # We should not use wildchars here. This could mask missing files problems
201 # -- morcego
202 %config %{privoxyconf}/config
203 %config %{privoxyconf}/advanced.action
204 %config %{privoxyconf}/basic.action
205 %config %{privoxyconf}/intermediate.action
206 %config %{privoxyconf}/default.action
207 %config %{privoxyconf}/default.filter
208 %config %{privoxyconf}/trust
209
210 %config %{privoxyconf}/templates/blocked
211 %config %{privoxyconf}/templates/blocked-compact
212 %config %{privoxyconf}/templates/cgi-error-404
213 %config %{privoxyconf}/templates/cgi-error-bad-param
214 %config %{privoxyconf}/templates/cgi-error-disabled
215 %config %{privoxyconf}/templates/cgi-error-file
216 %config %{privoxyconf}/templates/cgi-error-modified
217 %config %{privoxyconf}/templates/cgi-error-parse
218 %config %{privoxyconf}/templates/connect-failed
219 %config %{privoxyconf}/templates/default
220 %config %{privoxyconf}/templates/edit-actions-add-url-form
221 %config %{privoxyconf}/templates/edit-actions-for-url
222 %config %{privoxyconf}/templates/edit-actions-list
223 %config %{privoxyconf}/templates/edit-actions-list-section
224 %config %{privoxyconf}/templates/edit-actions-list-url
225 %config %{privoxyconf}/templates/edit-actions-remove-url-form
226 %config %{privoxyconf}/templates/edit-actions-url-form
227 %config %{privoxyconf}/templates/no-such-domain
228 %config %{privoxyconf}/templates/show-request
229 %config %{privoxyconf}/templates/show-status
230 %config %{privoxyconf}/templates/show-status-file
231 %config %{privoxyconf}/templates/show-url-info
232 %config %{privoxyconf}/templates/show-version
233 %config %{privoxyconf}/templates/toggle
234 %config %{privoxyconf}/templates/toggle-mini
235 %config %{privoxyconf}/templates/untrusted
236
237 %config %{_sysconfdir}/logrotate.d/%{name}
238 %config %attr(0744,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
239 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc0.d/K09%{name}
240 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc1.d/K09%{name}
241 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc2.d/S84%{name}
242 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc3.d/S84%{name}
243 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc4.d/S84%{name}
244 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc5.d/S84%{name}
245 #%%config(missingok) %attr(-,root,root) %{_sysconfdir}/rc.d/rc6.d/S84%{name}
246
247 %{_mandir}/man1/%{name}.*
248
249 %changelog
250 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
251 + junkbusterng-2.9.13-1
252   Added autoheader. Added autoconf to buildrequires.
253
254 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
255 + junkbusterng-2.9.13-1
256 - Fixed build problems re: name conflicts with man page and logrotate.
257 - Commented out rc?d/* configs for time being, which are causing a build 
258 - failure. /etc/junkbuster is now /etc/privoxy. Stefan did other name 
259 - changes. Fixed typo ';' should be ':' causing 'rpm -e' to fail.
260
261 * Fri Mar 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
262 + junkbusterng-2.9.13-1
263 - References to the expression ijb where changed where possible
264 - New package name: junkbusterng (all in lower case, acording to
265   the LSB recomendation)
266 - Version changed to: 2.9.13
267 - Release: 1
268 - Added: junkbuster to obsoletes and conflicts (Not sure this is
269   right. If it obsoletes, why conflict ? Have to check it later)
270 - Summary changed: Stefan, please check and aprove it
271 - Changes description to use the new name
272 - Sed string was NOT changed. Have to wait to the manpage to
273   change first
274 - Keeping the user junkbuster for now. It will require some aditional
275   changes on the script (scheduled for the next specfile release)
276 - Added post entry to move the old logfile to the new log directory
277 - Removing "chkconfig --add" entry (not good to have it automaticaly
278   added to the startup list).
279 - Added preun section to stop the service with the old name, as well
280   as remove it from the startup list
281 - Removed the chkconfig --del entry from the conditional block on
282   the preun scriptlet (now handled on the %files section)
283
284 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
285 - added ijb_docs.css to docs.
286
287 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
288 + junkbuster-2.9.11-8 
289 - Take out --enable-no-gifs, breaks some browsers.
290
291 * Sun Mar 10 2002 Hal Burgiss <hal@foobox.net>
292 + junkbuster-2.9.11-8 
293 - Add --enable-no-gifs to configure.
294
295 * Fri Mar 08 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
296 + junkbuster-2.9.11-7
297 - Added BuildRequires to libtool.
298
299 * Tue Mar 06 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
300 + junkbuster-2.9.11-6
301 - Changed the routined that handle the junkbust and junkbuster users on
302   %%pre and %%post to work in a smoother manner
303 - %%files now uses hardcoded usernames, to avoid problems with package
304   name changes in the future
305
306 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
307 + junkbuster-2.9.11-5
308 - Added "make redhat-dok" to the build process
309 - Added docbook-utils to BuildRequires
310
311 * Tue Mar 05 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
312 + junkbuster-2.9.11-4
313 - Changing man section in the manpage from 1 to 8
314 - We now require packages, not files, to avoid issues with apt
315
316 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
317 + junkbuster-2.9.11-3
318 - Fixing permissions of the init script
319
320 * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
321 + junkbuster-2.9.11-2
322 - General specfile fixup, using the best recomended practices, including:
323         - Adding -q to %%setup
324         - Using macros whereever possible
325         - Not using wildchars on %%files section
326         - Doubling the percentage char on changelog and comments, to
327           avoid rpm expanding them
328
329 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
330 - /bin/false for shell causes init script to fail. Reverting.
331
332 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
333 - Removed UID 73. Included user-manual and developer-manual in docs.
334   Include other actions files. Default shell is now /bin/false.
335   Userdel user=junkbust. ChangeLog was not zipped. Removed 
336   RPM_OPT_FLAGS kludge.
337
338 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
339 - add paranoia check for 'rm -rf %%{buildroot}'
340 - add gzip to 'BuildRequires'
341
342 * Sat Dec  1 2001 Hal Burgiss <hal@foobox.net>
343 - actionsfile is now ijb.action.
344
345 * Tue Nov  6 2001 Thomas Steudten <thomas@steudten.ch>
346 - Compress manpage
347 - Add more documents for installation
348 - Add version string to name and source
349
350 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
351 - Back to user 'junkbuster' and fix configure macro.
352
353 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
354 - More changes for user 'junkbust'. Init script had 'junkbuster'.
355
356 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
357 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
358 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
359
360 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
361 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and 
362 - made sure no default shell exists for user junkbust.
363
364 * Sun Jun  3 2001 Stefan Waldherr <stefan@waldherr.org>
365 - rework of RPM
366
367 * Mon Sep 25 2000 Stefan Waldherr <stefan@waldherr.org>
368 - CLF Logging patch by davep@cyw.uklinux.net
369 - Hal DeVore <haldevore@earthling.net> fix akamaitech in blocklist
370
371 * Sun Sep 17 2000 Stefan Waldherr <stefan@waldherr.org>
372 - Steve Kemp skx@tardis.ed.ac.uk's javascript popup patch.
373 - Markus Breitenbach breitenb@rbg.informatik.tu-darmstadt.de supplied
374   numerous fixes and enhancements for Steve's patch.
375 - adamlock@netscape.com (Adam Lock) in the windows version:
376   - Taskbar activity spinner always spins even when logging is
377   turned off (which is the default) - people who don't
378   like the spinner can turn it off from a menu option.
379   - Taskbar popup menu has a options submenu - people can now
380   open the settings files for cookies, blockers etc.
381   without opening the JB window.
382   - Logging functionality works again
383   - Buffer overflow is fixed - new code uses a bigger buffer
384   and snprintf so it shouldn't overflow anymore.
385 - Fixed userid swa, group learning problem while installing.
386   root must build RPM.
387 - Added patch by Benjamin Low <ben@snrc.uow.edu.au> that prevents JB to
388   core dump when there is no log file.
389 - Tweaked SuSE startup with the help of mohataj@gmx.net and Doc.B@gmx.de.
390 - Fixed man page to include imagefile and popupfile.
391 - Sanity check for the statistics function added.
392 - "Patrick D'Cruze" <pdcruze@orac.iinet.net.au>: It seems Microsoft
393  are transitioning Hotmail from FreeBSD/Apache to Windows 2000/IIS.
394  With IIS/5, it appears to omit the trailing \r\n from http header
395  only messages.  eg, when I visit http://www.hotmail.com, IIS/5
396  responds with a HTTP 302 redirect header.  However, this header
397  message is missing the trailing \r\n.  IIS/5 then closes the
398  connection.  Junkbuster, unfortunately, discards the header becomes
399  it thinks it is incomplete - and it is.  MS have transmitted an
400  incomplete header!
401 - Added bug reports and patch submission forms in the docs.
402
403 * Mon Mar 20 2000 Stefan Waldherr <stefan@waldherr.org>
404        Andrew <anw@tirana.freewire.co.uk> extended the JB:
405        Display of statistics of the total number of requests and the number
406        of requests filtered by junkbuster, also the percentage of requests
407        filtered. Suppression of the listing of files on the proxy-args page.
408        All stuff optional and configurable.
409
410 * Sun Sep 12 1999 Stefan Waldherr <stefan@waldherr.org>
411        Jan Willamowius (jan@janhh.shnet.org) fixed a bug in the 
412        code which prevented the JB from handling URLs of the form
413        user:password@www.foo.com. Fixed.
414
415 * Mon Aug  2 1999 Stefan Waldherr <stefan@waldherr.org>
416         Blank images are no longer cached, thanks to a hint from Markus 
417         Breitenbach <breitenb@rbg.informatik.tu-darmstadt.de>. The user 
418         agent is NO longer set by the Junkbuster. Sadly, many sites depend 
419         on the correct browser version nowadays. Incorporated many 
420         suggestions from Jan "Yenya" Kasprzak <kas@fi.muni.cz> for the
421         spec file. Fixed logging problem and since runlevel 2 does not 
422         use networking, I replaced /etc/rc.d/rc2.d/S84junkbuster with
423         /etc/rc.d/rc2.d/K09junkbuster thanks to Shaw Walker 
424         <walker@netgate.net>. You should now be able to build this RPM as 
425         a non-root user (mathias@weidner.sem.lipsia.de).
426
427 * Sun Jan 31 1999 Stefan Waldherr <stefan@waldherr.org>
428         %%{_localstatedir}/log/junkbuster set to nobody. Added /etc/junkbuster/imagelist
429         to allow more sophisticated matching of blocked images. Logrotate
430         logfile. Added files for auto-updating the blocklist et al.
431
432 * Wed Dec 16 1998 Stefan Waldherr <stefan@waldherr.org>
433         Configure blank version via config file. No separate blank
434         version anymore. Added Roland's <roland@spinnaker.rhein.de>
435         patch to show a logo instead of a blank area. Added a suggestion
436         from Alex <alex@cocoa.demon.co.uk>: %%{_localstatedir}/lock/subsys/junkbuster.
437         More regexps in the blocklist. Prepared the forwardfile for
438         squid. Extended image regexp with help from gabriel 
439         <somlo@CS.ColoState.EDU>.
440
441 * Thu Nov 19 1998 Stefan Waldherr <stefan@waldherr.org>
442         All RPMs now identify themselves in the show-proxy-args page.
443         Released Windoze version. Run junkbuster as nobody instead of
444         root. 
445
446 * Fri Oct 30 1998 Stefan Waldherr <stefan@waldherr.org>
447         Newest version. First release (hence the little version number
448         mixture -- 2.0.2-0 instead of 2.0-7). This version tightens 
449         security over 2.0.1; some multi-user sites will need to change 
450         the listen-address in the configuration file. The blank version of
451         the Internet Junkbuster has a more sophisticated way of replacing
452         images. All RPMs identify themselves in the show-proxy-args page.
453
454 * Thu Sep 23 1998 Stefan Waldherr <stefan@waldherr.org>
455         Modified the blocking feature, so that only GIFs and JPEGs are
456         blocked and replaced but not HTML pages. Thanks to 
457         "Gerd Flender" <plgerd@informatik.uni-siegen.de> for this nice
458         idea. Added numerous stuff to the blocklist. Keep patches in
459         seperate files and no longer in diffs (easier to maintain).
460
461 * Tue Jun 16 1998 Stefan Waldherr <swa@cs.cmu.edu>
462         Moved config files to /etc/junkbuster directory, moved man page,
463         added BuildRoot directive (Thanks to Alexey Nogin <ayn2@cornell.edu>)
464         Made new version junkbuster-raw (which is only a stripped version of 
465         the junkuster rpm, i.e. without my blocklist, etc.)
466
467 * Tue Jun 16 1998 (2.0-1)
468         Uhm, not that much. Just a new junkbuster version that
469         fixes a couple of bugs ... and of course a bigger 
470         blocklist with the unique Now-less-ads-than-ever(SM)
471         feature.
472         Oh, one thing: I changed the default user agent to Linux -- no 
473         need anymore to support Apple.
474
475 * Tue Jun 16 1998 (2.0-0)
476         Now-less-ads-than-ever (SM)
477         compiled with gcc instead of cc
478         compiled with -O3, thus it should be a little faster
479         show-proxy-args now works
480         /etc/junkbuster.init wasn't necessary
481
482 * Tue Jun 16 1998 (1.4)
483         some more config files were put into /etc
484         The junkbuster-blank rpm returns a 1x1 pixel image, that gets 
485         displayed by Netscape instead of the blocked image.
486         Read http://www.waldherr.org/junkbuster/ for
487         further info.
488
489 * Tue Jun 16 1998 (1.3)
490         The program has been moved to /usr/sbin (from /usr/local/bin)
491         Init- and stopscripts (/etc/rc.d/rc*) have been added so
492         that the junkbuster starts automatically during bootup.
493         The /etc/blocklist file is much more sophisticated. Theoretically
494         one should e.g. browse all major US and German newspapers without
495         seeing one annoying ad.
496         junkbuster.init was modified. It now starts junkbuster with an
497         additional "-r @" flag.
498
499 # $Log: privoxy-rh.spec,v $
500 # Revision 1.7  2002/03/24 21:07:18  hal9
501 # Add autoheader, etc.
502 #
503 # Revision 1.6  2002/03/24 19:56:40  hal9
504 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
505 #
506 # Revision 1.4  2002/03/24 13:32:42  swa
507 # name change related issues
508 #
509 # Revision 1.3  2002/03/24 12:56:21  swa
510 # name change related issues.
511 #
512 # Revision 1.2  2002/03/24 11:40:14  swa
513 # name change
514 #
515 # Revision 1.1  2002/03/24 11:23:44  swa
516 # name change
517 #
518 # Revision 1.1  2002/03/22 20:53:03  morcego
519 # - Ongoing process to change name to JunkbusterNG
520 # - configure/configure.in: no change needed
521 # - GNUmakefile.in:
522 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
523 #         - PROGRAM    = jbng@EXEEXT@
524 #         - rh-spec now references as junkbusterng-rh.spec
525 #         - redhat-upload: references changed to junkbusterng-* (package names)
526 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
527 #         - tarball-src: now JunkbusterNG-*
528 #         - install: initscript now junkbusterng.init and junkbusterng (when
529 #                    installed)
530 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
531 # - junkbusterng.spec:
532 #         - References to the expression ijb where changed where possible
533 #         - New package name: junkbusterng (all in lower case, acording to
534 #           the LSB recomendation)
535 #         - Version changed to: 2.9.13
536 #         - Release: 1
537 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
538 #           right. If it obsoletes, why conflict ? Have to check it later)
539 #         - Summary changed: Stefan, please check and aprove it
540 #         - Changes description to use the new name
541 #         - Sed string was NOT changed. Have to wait to the manpage to
542 #           change first
543 #         - Keeping the user junkbuster for now. It will require some aditional
544 #           changes on the script (scheduled for the next specfile release)
545 #         - Added post entry to move the old logfile to the new log directory
546 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
547 #           added to the startup list).
548 #         - Added preun section to stop the service with the old name, as well
549 #           as remove it from the startup list
550 #         - Removed the chkconfig --del entry from the conditional block on
551 #           the preun scriptlet (now handled on the %files section)
552 # - junkbuster.init: renamed to junkbusterng.init
553 # - junkbusterng.init:
554 #         - Changed JB_BIN to jbng
555 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
556 #           be used where necessary (config dir)
557 #
558 # Aditional notes:
559 # - The config directory is /etc/junkbuster yet. Have to change it on the
560 # specfile, after it is changes on the code
561 # - The only files that got renamed on the cvs tree were the rh specfile and
562 # the init file. Some file references got changes on the makefile and on the
563 # rh-spec (as listed above)
564 #
565 # Revision 1.43  2002/03/21 16:04:10  hal9
566 # added ijb_docs.css to %doc
567 #
568 # Revision 1.42  2002/03/12 13:41:18  sarantis
569 # remove hard-coded "ijbswa" string in build phase
570 #
571 # Revision 1.41  2002/03/11 22:58:32  hal9
572 # Remove --enable-no-gifs
573 #
574 # Revision 1.39  2002/03/08 18:57:29  swa
575 # remove user junkbuster after de-installation.
576 #
577 # Revision 1.38  2002/03/08 13:45:27  morcego
578 # Adding libtool to Buildrequires
579 #
580 # Revision 1.37  2002/03/07 19:23:49  swa
581 # i hate to scroll. suse: wrong configdir.
582 #
583 # Revision 1.36  2002/03/07 05:06:54  morcego
584 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
585 #
586 # Revision 1.34  2002/03/07 00:11:57  morcego
587 # Few changes on the %pre and %post sections of the rh specfile to handle
588 # usernames more cleanly
589 #
590 # Revision 1.33  2002/03/05 13:13:57  morcego
591 # - Added "make redhat-dok" to the build phase
592 # - Added docbook-utils to BuildRequires
593 #
594 # Revision 1.32  2002/03/05 12:34:24  morcego
595 # - Changing section internaly on the manpage from 1 to 8
596 # - We now require packages, not files, to avoid issues with apt
597 #
598 # Revision 1.31  2002/03/04 18:06:09  morcego
599 # SPECFILE: fixing permissing of the init script (broken by the last change)
600 #
601 # Revision 1.30  2002/03/04 16:18:03  morcego
602 # General cleanup of the rh specfile.
603 #
604 # %changelog
605 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
606 # + junkbuster-2.9.11-2
607 # - General specfile fixup, using the best recomended practices, including:
608 #         - Adding -q to %%setup
609 #         - Using macros whereever possible
610 #         - Not using wildchars on %%files section
611 #         - Doubling the percentage char on changelog and comments, to
612 #           avoid rpm expanding them
613 #
614 # Revision 1.29  2002/03/03 19:21:22  hal9
615 # Init script fails if shell is /bin/false.
616 #
617 # Revision 1.28  2002/01/09 18:34:03  hal9
618 # nit.
619 #
620 # Revision 1.27  2002/01/09 18:32:02  hal9
621 # Removed RPM_OPT_FLAGS kludge.
622 #
623 # Revision 1.26  2002/01/09 18:21:10  hal9
624 # A few minor updates.
625 #
626 # Revision 1.25  2001/12/28 01:45:36  steudten
627 # Add paranoia check and BuildReq: gzip
628 #
629 # Revision 1.24  2001/12/01 21:43:14  hal9
630 # Allowed for new ijb.action file.
631 #
632 # Revision 1.23  2001/11/06 12:09:03  steudten
633 # Compress doc files. Install README and AUTHORS at last as document.
634 #
635 # Revision 1.22  2001/11/05 21:37:34  steudten
636 # Fix to include the actual version for name.
637 # Let the 'real' packager be included - sorry stefan.
638 #
639 # Revision 1.21  2001/10/31 19:27:27  swa
640 # consistent description. new name for suse since
641 # we had troubles with rpms of identical names
642 # on the webserver.
643 #
644 # Revision 1.20  2001/10/24 15:45:49  hal9
645 # To keep Thomas happy (aka correcting my  mistakes)
646 #
647 # Revision 1.19  2001/10/15 03:23:59  hal9
648 # Nits.
649 #
650 # Revision 1.17  2001/10/10 18:59:28  hal9
651 # Minor change for init script.
652 #
653 # Revision 1.16  2001/09/24 20:56:23  hal9
654 # Minor changes.
655 #
656 # Revision 1.13  2001/09/10 17:44:43  swa
657 # integrate three pieces of documentation. needs work.
658 # will not build cleanly under redhat.
659 #
660 # Revision 1.12  2001/09/10 16:25:04  swa
661 # copy all templates. version updated.
662 #
663 # Revision 1.11  2001/07/03 11:00:25  sarantis
664 # replaced permissionsfile with actionsfile
665 #
666 # Revision 1.10  2001/07/03 09:34:44  sarantis
667 # bumped up version number.
668 #
669 # Revision 1.9  2001/06/12 18:15:29  swa
670 # the %% in front of configure (see tag below) confused
671 # the rpm build process on 7.1.
672 #
673 # Revision 1.8  2001/06/12 17:15:56  swa
674 # fixes, because a clean build on rh6.1 was impossible.
675 # GZIP confuses make, %% configure confuses rpm, etc.
676 #
677 # Revision 1.7  2001/06/11 12:17:26  sarantis
678 # fix typo in %%post
679 #
680 # Revision 1.6  2001/06/11 11:28:25  sarantis
681 # Further optimizations and adaptations in the spec file.
682 #
683 # Revision 1.5  2001/06/09 09:14:11  swa
684 # shamelessly adapted RPM stuff from the newest rpm that
685 # RedHat provided for the JB.
686 #
687 # Revision 1.4  2001/06/08 20:54:18  swa
688 # type with status file. remove forward et. al from file list.
689 #
690 # Revision 1.3  2001/06/07 17:28:10  swa
691 # cosmetics
692 #
693 # Revision 1.2  2001/06/04 18:31:58  swa
694 # files are now prefixed with either `confdir' or `logdir'.
695 # `make redhat-dist' replaces both entries confdir and logdir
696 # with redhat values
697 #
698 # Revision 1.1  2001/06/04 10:44:57  swa
699 # `make redhatr-dist' now works. Except for the paths
700 # in the config file.
701 #
702 #
703 #