1 # $Id: privoxy-suse.spec,v 1.20.2.10 2004/01/30 17:09:29 oes Exp $
3 # Written by and Copyright (C) 2001 the SourceForge
4 # Privoxy team. http://www.privoxy.org/
6 # Based on the Internet Junkbuster originally written
7 # by and Copyright (C) 1997 Anonymous Coders and
8 # Junkbusters Corporation. http://www.junkbusters.com
10 # This program is free software; you can redistribute it
11 # and/or modify it under the terms of the GNU General
12 # Public License as published by the Free Software
13 # Foundation; either version 2 of the License, or (at
14 # your option) any later version.
16 # This program is distributed in the hope that it will
17 # be useful, but WITHOUT ANY WARRANTY; without even the
18 # implied warranty of MERCHANTABILITY or FITNESS FOR A
19 # PARTICULAR PURPOSE. See the GNU General Public
20 # License for more details.
22 # The GNU General Public License should be included with
23 # this file. If not, you can view it at
24 # http://www.gnu.org/copyleft/gpl.html
25 # or write to the Free Software Foundation, Inc., 59
26 # Temple Place - Suite 330, Boston, MA 02111-1307, USA.
29 # do not set to %{name}
30 %define privoxyconf %{_sysconfdir}/privoxy
31 %define privoxy_uid 73
32 %define privoxy_gid 73
35 Summary: Privoxy - privacy enhancing proxy
38 Distribution: defineme
41 # Needs makefile change: Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}-%{status}-src.tar.gz
42 Source: http://prdownloads.sourceforge.net/ijbswa/privoxy-%{version}.tar.gz
43 # not sure if this works
44 BuildRoot: %{_tmppath}/%{name}-%{version}-root
45 Packager: Stefan Waldherr <stefan@waldherr.org>
47 Group: Networking/Utilities
48 URL: http://www.privoxy.org/
50 BuildRequires: perl gzip libtool autoconf
51 Conflicts: junkbuster-raw junkbuster-blank junkbuster-suse junkbuster privoxy
54 # -----------------------------------------------------------------------------
57 Privoxy is a web proxy with advanced filtering capabilities for
58 protecting privacy, modifying web page content, managing cookies,
59 controlling access, and removing ads, banners, pop-ups and other
60 obnoxious Internet junk. Privoxy has a very flexible configuration and
61 can be customized to suit individual needs and tastes. Privoxy has
62 application for both stand-alone systems and multi-user networks.
64 Privoxy is based on the Internet Junkbuster.
68 http://www.privoxy.org/
73 # -----------------------------------------------------------------------------
79 # -----------------------------------------------------------------------------
84 ./configure --disable-dynamic-pcre
88 ## Explicitily stripping is not recomended.
89 ## This is handled altomaticaly by RPM, and can couse troubles if
90 ## anyone wants to build an unstriped version - morcego
94 # -----------------------------------------------------------------------------
97 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
98 mkdir -p ${RPM_BUILD_ROOT}%{_sbindir} \
99 ${RPM_BUILD_ROOT}%{_mandir}/man8 \
100 ${RPM_BUILD_ROOT}/var/log/privoxy \
101 ${RPM_BUILD_ROOT}%{privoxyconf}/templates \
102 ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d \
103 ${RPM_BUILD_ROOT}%{_sysconfdir}/init.d
104 gzip README AUTHORS ChangeLog privoxy.1 LICENSE || /bin/true
105 install -s -m 744 privoxy $RPM_BUILD_ROOT%{_sbindir}/privoxy
106 cp -f privoxy.1.gz $RPM_BUILD_ROOT%{_mandir}/man8/privoxy.8.gz
107 cp -f *.action $RPM_BUILD_ROOT%{privoxyconf}/
108 cp -f default.filter $RPM_BUILD_ROOT%{privoxyconf}/default.filter
109 cp -f trust $RPM_BUILD_ROOT%{privoxyconf}/trust
110 cp -f templates/* $RPM_BUILD_ROOT%{privoxyconf}/templates/
111 cp -f privoxy.logrotate $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/privoxy
112 install -m 755 privoxy.init.suse $RPM_BUILD_ROOT%{_sysconfdir}/init.d/privoxy
113 install -m 711 -d $RPM_BUILD_ROOT/var/log/privoxy
114 ln -sf /etc/init.d/privoxy $RPM_BUILD_ROOT/usr/sbin/rcprivoxy
116 # verify all file locations, etc. in the config file
117 # don't start with ^ or commented lines are not replaced
119 sed 's/^confdir.*/confdir \/etc\/privoxy/g' | \
120 # sed 's/^permissionsfile.*/permissionsfile \/etc\/privoxy\/permissionsfile/g' | \
121 # sed 's/^filterfile.*/default.filter \/etc\/privoxy\/default.filter/g' | \
122 # sed 's/^logfile.*/logfile \/var\/log\/privoxy\/logfile/g' | \
123 # sed 's/^jarfile.*/jarfile \/var\/log\/privoxy\/jarfile/g' | \
124 # sed 's/^forward.*/forward \/etc\/privoxy\/forward/g' | \
125 # sed 's/^aclfile.*/aclfile \/etc\/privoxy\/aclfile/g' > \
126 sed 's/^logdir.*/logdir \/var\/log\/privoxy/g' > \
127 $RPM_BUILD_ROOT%{privoxyconf}/config
130 # -----------------------------------------------------------------------------
133 # We check to see if the user privoxy exists.
134 # If it does, we do nothing
135 # If we don't, we check to see if the user junkbust exist and, in case it
136 # does, we change it do privoxy. If it also does not exist, we create the
137 # privoxy user -- morcego
138 id privoxy > /dev/null 2>&1
139 if [ $? -eq 1 ]; then
140 id junkbust > /dev/null 2>&1
141 if [ $? -eq 0 ]; then
142 /usr/sbin/usermod -u %{privoxy_uid} -g %{privoxy_gid} -l privoxy -d %{_sysconfdir}/privoxy -s "" junkbust > /dev/null 2>&1
144 # -r does not work on suse.
145 /usr/sbin/groupadd -g %{privoxy_gid} privoxy
146 /usr/sbin/useradd -u %{privoxy_uid} -d %{_sysconfdir}/privoxy -g privoxy -s "" privoxy > /dev/null 2>&1
151 # -----------------------------------------------------------------------------
154 [ -f /var/log/privoxy/privoxy ] &&\
155 mv -f /var/log/privoxy/privoxy /var/log/privoxy/logfile || /bin/true
156 chown -R privoxy:privoxy /var/log/privoxy 2>/dev/null
157 chown -R privoxy:privoxy /etc/privoxy 2>/dev/null
158 # not available on suse
159 #if [ "$1" = "1" ]; then
160 # /sbin/chkconfig --add privoxy
161 # /sbin/service privoxy condrestart > /dev/null 2>&1
163 # 01/09/02 HB, getting rid of any user=junkbust
164 # Changed by morcego to use the id command.
165 id junkbust > /dev/null 2>&1 && /usr/sbin/userdel junkbust || /bin/true
166 sbin/insserv etc/init.d/privoxy
169 # -----------------------------------------------------------------------------
172 # need to stop the service on suse. swa.
173 #if [ "$1" = "0" ]; then
174 # /sbin/service privoxy stop > /dev/null 2>&1 ||:
178 # -----------------------------------------------------------------------------
181 sbin/insserv etc/init.d/
182 # dont forget to remove user and group privoxy
183 id privoxy > /dev/null 2>&1 && /usr/sbin/userdel privoxy || /bin/true
186 # -----------------------------------------------------------------------------
189 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
192 # -----------------------------------------------------------------------------
195 %defattr(-,root,root)
196 %doc README.gz AUTHORS.gz ChangeLog.gz LICENSE.gz
197 %doc doc/webserver/developer-manual
198 %doc doc/webserver/user-manual
199 %doc doc/webserver/faq
200 %doc doc/webserver/p_doc.css
201 %doc doc/webserver/privoxy-index.html
202 %doc doc/webserver/images
203 %doc doc/webserver/man-page
206 %config %{privoxyconf}/*
207 %attr(0740,privoxy,privoxy) %dir /var/log/privoxy
208 %config %{_sysconfdir}/logrotate.d/privoxy
209 %attr(0755,root,root)/usr/sbin/privoxy
211 %config %{_sysconfdir}/init.d/privoxy
215 # -----------------------------------------------------------------------------
218 * Wed Mar 26 2003 Andreas Oesterhelt <andreas@oesterhelt.org>
219 - Bump version for 3.0.2.
221 * Wed Mar 19 2003 Hal Burgiss <hal@foobox.net>
222 - Bump version for 3.0.1.
224 * Tue Aug 25 2002 Hal Burgiss <hal@foobox.net>
225 - Bump version for 3.0.0 :)
227 * Tue Aug 06 2002 Hal Burgiss <hal@foobox.net>
228 - Reset version for 2.9.18.
230 * Wed Jul 30 2002 Hal Burgiss <hal@foobox.net>
231 - Reset version for 2.9.17.
233 * Sat Jul 27 2002 Hal Burgiss <hal@foobox.net>
234 - Reset version and release for 2.9.16.
236 * Mon May 27 2002 Hal Burgiss <hal@foobox.net>
238 - Index.html is now privoxy-index.html for doc usage.
240 * Mon May 27 2002 Hal Burgiss <hal@foobox.net>
242 - Index.html is now privoxy-index.html for doc usage.
244 * Sat May 25 2002 Hal Burgiss <hal@foobox.net>
246 - Add html man page so index.html does not 404.
248 * Fri May 24 2002 Hal Burgiss <hal@foobox.net>
250 - Add doc/images directory.
252 * Fri May 03 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
253 + privoxy-suse-2.9.15-1
256 * Fri Apr 26 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
257 + privoxy-suse-2.9.14-3
258 - Changing Vendor to Privoxy.Org
260 * Mon Apr 22 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
261 + privoxy-suse-2.9.14-2
262 - Bumping release to reflect the new value on configure.in
263 - Taking the oportunity to change the header Copyright to License. The
264 Copyright headers is deprecated, and after all, GPL is a license, not a
267 * Mon Apr 08 2002 Hal Burgiss <hal@foobox.net>
269 - Add LICENSE.gz, p_web.css, and index.html. Add autoconf
272 * Wed Mar 27 2002 Hal Burgiss <hal@foobox.net>
274 - Doc css has changed names.
276 * Tue Mar 25 2002 Hal Burgiss <hal@foobox.net>
278 - Minor fix to description.
280 * Sun Mar 24 2002 Hal Burgiss <hal@foobox.net>
283 * Thu Mar 21 2002 Hal Burgiss <hal@foobox.net>
284 - added ijb_docs.css to docs.
286 * Mon Mar 11 2002 Hal Burgiss <hal@foobox.net>
287 - Remove --enable-no-gifs from configure.
289 * Sun Mar 03 2002 Hal Burgiss <hal@foobox.net>
290 - /bin/false for shell causes init script to fail. Reverting.
292 * Wed Jan 09 2002 Hal Burgiss <hal@foobox.net>
293 - Removed UID 73. Included user-manual and developer-manual in docs.
294 Include other actions files. Default shell is now /bin/false.
295 Userdel user=junkbust. ChangeLog was not zipped. Removed
296 RPM_OPT_FLAGS kludge.
298 * Fri Dec 28 2001 Thomas Steudten <thomas@steudten.ch>
299 - add paranoia check for 'rm -rf $RPM_BUILD_ROOT'
300 - add gzip to 'BuildRequires'
302 * Sat Dec 1 2001 Hal Burgiss <hal@foobox.net>
303 - actionsfile is now ijb.action.
305 * Tue Nov 6 2001 Thomas Steudten <thomas@steudten.ch>
307 - Add more documents for installation
308 - Add version string to name and source
310 * Wed Oct 24 2001 Hal Burigss <hal@foobox.net>
311 - Back to user 'junkbuster' and fix configure macro.
313 * Wed Oct 10 2001 Hal Burigss <hal@foobox.net>
314 - More changes for user 'junkbust'. Init script had 'junkbuster'.
316 * Sun Sep 23 2001 Hal Burgiss <hal@foobox.net>
317 - Change of $RPM_OPT_FLAGS handling. Added new HTML doc files.
318 - Changed owner of /etc/junkbuster to shut up PAM/xauth log noise.
320 * Thu Sep 13 2001 Hal Burgiss <hal@foobox.net>
321 - Added $RPM_OPT_FLAGS support, renaming of old logfile, and
322 - made sure no default shell exists for user junkbust.
324 * Sun Jun 3 2001 Stefan Waldherr <stefan@waldherr.org>
326 * Wed Feb 14 2001 - uli@suse.de
328 * Wed Dec 06 2000 - bjacke@suse.de
329 - renamed package to junkbuster
330 - fixed copyright tag
331 * Thu Nov 30 2000 - uli@suse.de
332 - moved init script to /etc/init.d
333 * Wed Feb 16 2000 - kukuk@suse.de
334 - Move /usr/man -> /usr/share/man
335 - Mark /etc/ijb as "config(noreplace)"
336 * Mon Sep 20 1999 - uli@suse.de
338 * Mon Sep 13 1999 - bs@suse.de
339 - ran old prepare_spec on spec file to switch to new prepare_spec.
340 * Thu Apr 01 1999 - daniel@suse.de
341 - do not start ijb as root (security)
342 * Tue Mar 30 1999 - daniel@suse.de
343 - donĀ“t use saclfile.ini
344 * Tue Mar 30 1999 - daniel@suse.de
345 - small fix to whitelist-configuration,
346 version is and was 2.0.2 WITHOUT Stefan Waldherr's patches
347 (http://www.waldherr.org/junkbuster/)
348 * Mon Mar 01 1999 - daniel@suse.de
349 - new package: version 2.0
351 # $Log: privoxy-suse.spec,v $
352 # Revision 1.20.2.10 2004/01/30 17:09:29 oes
353 # Bumped version for 3.0.3
355 # Revision 1.20.2.9 2003/03/26 00:24:58 oes
356 # Bump version for 3.0.2
358 # Revision 1.20.2.8 2003/03/20 03:27:11 hal9
359 # Bump version for 3.0.1 pending release.
361 # Revision 1.20.2.7 2002/08/25 23:36:03 hal9
362 # Bump version for 3.0.0.
364 # Revision 1.20.2.6 2002/08/10 11:28:50 oes
367 # Revision 1.20.2.5 2002/08/07 01:08:49 hal9
368 # Bumped version to 2.9.18.
370 # Revision 1.20.2.4 2002/07/30 21:51:19 hal9
371 # Bump version to 2.9.17.
373 # Revision 1.20.2.3 2002/07/27 15:47:10 hal9
374 # Reset version and release for 2.9.16.
376 # Revision 1.20.2.2 2002/05/28 02:39:38 hal9
377 # Replace index.html with privoxy-index.html for docs.
379 # Revision 1.20.2.1 2002/05/26 17:20:23 hal9
380 # Add images to doc dirs.
382 # Revision 1.20 2002/05/25 02:08:23 hal9
383 # Add doc/images directory.
384 # Redhat: alphabetized list of templates (and I think added one in the process)
386 # Revision 1.19 2002/05/03 17:14:36 morcego
387 # *.spec: Version bump to 2.9.15
388 # -rh.spec: noreplace for %%{privoxyconf}/config
389 # Will interrupt the build if versions from configure.in and
390 # specfile do not match
392 # Revision 1.18 2002/04/27 20:26:59 swa
393 # uid, gui 73 incorporated
395 # Revision 1.17 2002/04/26 15:51:05 morcego
396 # Changing Vendor value to Privoxy.Org
398 # Revision 1.16 2002/04/22 16:32:31 morcego
399 # configure.in, *.spec: Bumping release to 2 (2.9.14-2)
400 # -rh.spec: uid and gid are now macros
401 # -suse.spec: Changing the header Copyright to License (Copyright is
404 # Revision 1.15 2002/04/16 18:49:07 oes
405 # Build with static built-in pcre
407 # Revision 1.14 2002/04/11 17:57:40 oes
408 # Fixed(?) Conflicts: Provides: Obsoletes:
410 # Revision 1.13 2002/04/11 10:09:20 oes
413 # Revision 1.12 2002/04/09 13:29:43 swa
414 # build suse and gen-dist with html docs. do not generate docs while building rpm
416 # Revision 1.11 2002/04/09 03:12:37 hal9
417 # Add LICENSE, p_web.css and index.html. Add autoconf to buildrequires.
419 # Revision 1.10 2002/04/08 20:24:13 swa
422 # Revision 1.9 2002/03/30 09:01:52 swa
425 # Revision 1.8 2002/03/27 23:46:41 hal9
426 # ijb_docs.css to p_doc.css
428 # Revision 1.7 2002/03/27 00:49:39 hal9
429 # Minor fix to description.
431 # Revision 1.6 2002/03/26 22:29:55 swa
432 # we have a new homepage!
434 # Revision 1.5 2002/03/25 03:10:50 hal9
437 # Revision 1.4 2002/03/24 12:56:21 swa
438 # name change related issues.
440 # Revision 1.3 2002/03/24 12:44:31 swa
443 # Revision 1.2 2002/03/24 11:40:14 swa
446 # Revision 1.1 2002/03/24 11:23:44 swa
449 # Revision 1.21 2002/03/21 16:04:33 hal9
450 # added ijb_docs.css to %%doc
452 # Revision 1.20 2002/03/12 13:42:14 sarantis
453 # remove hardcoded "ijbswa" from build phase
455 # Revision 1.19 2002/03/11 22:59:05 hal9
456 # Remove --enable-no-gifs
458 # Revision 1.18 2002/03/11 12:30:31 swa
459 # be consistent with rh spec file
461 # Revision 1.17 2002/03/08 19:30:23 swa
462 # remove user junkbuster after de-installation.
463 # synced suse with rh-specfile. installation
464 # and de-installation seem to work.
466 # Revision 1.16 2002/03/08 18:40:44 swa
467 # build requires tools. useradd and del works
470 # Revision 1.15 2002/03/07 19:23:50 swa
471 # i hate to scroll. suse: wrong configdir.
473 # Revision 1.14 2002/03/07 19:10:21 swa
474 # builds cleanly. thanks to kukuk@suse.de
477 # Revision 1.13 2002/03/07 18:25:56 swa
478 # synced redhat and suse build process
480 # Revision 1.12 2002/03/02 15:50:04 swa
481 # 2.9.11 version. more input for docs.
483 # Revision 1.11 2001/12/02 10:29:26 swa
484 # New version made these changes necessary.
486 # Revision 1.10 2001/10/31 19:27:27 swa
487 # consistent description. new name for suse since
488 # we had troubles with rpms of identical names
491 # Revision 1.9 2001/10/26 18:17:23 swa
494 # Revision 1.8 2001/09/13 16:22:42 swa
495 # man page is legacy. suse rpm now contains html
498 # Revision 1.7 2001/09/10 17:44:22 swa
499 # integrate three pieces of documentation.
501 # Revision 1.6 2001/09/10 16:29:23 swa
502 # binary contained debug info.
503 # buildroot definition fucks up the build process under suse.
504 # program needs to write in varlogjunkbuster
505 # install all templates
506 # create varlogjunkbuster
508 # Revision 1.5 2001/06/09 09:13:29 swa
509 # description shorter
511 # Revision 1.4 2001/06/08 20:53:36 swa
512 # use buildroot, export init to separate file (better manageability)
514 # Revision 1.3 2001/06/07 17:28:10 swa
517 # Revision 1.2 2001/06/07 17:18:44 swa